USB hub stopped working

Discussion in 'Windows 7 Help and Support' started by wetzilla, Nov 3, 2010.

  1. wetzilla

    wetzilla New Member

    Joined:
    Apr 25, 2009
    Messages:
    8
    Likes Received:
    0
    I've had a 7 port rosewill usb hub connected to my computer for about a year now, and all of a sudden the other night it stopped working. Windows will no longer recognize it, and calls it an unknown device. It gives me the error 43, but so far uninstalling the usb devices hasn't seemed to work. I've only been able to uninstall one of the devices though, because as soon as I do that my keyboard and mouse stop working. I know the hub isn't broken, it works on every other computer, so it has to be something in windows. Any ideas?
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hi.

    Update the chipset drivers from the motherboard manufacturer's site. The code means that the hardware can not communicate with the motherboard.
     
  3. wetzilla

    wetzilla New Member

    Joined:
    Apr 25, 2009
    Messages:
    8
    Likes Received:
    0
    Ok, that worked, kind of. I updated the bios since I could would specific usb chipset drivers for my mobo, a asrock p55 pro, and the hub is now recognized. The only problem is now my various usb devices (including ones not plugged into the hub) will just stop working for a second (it makes the usb disconnected noise), and then start working (also making the usb connected noise). It's really annoying, I think I'm going to try the hub on a different computer for a while, see if it still happens, and if not, reformat the computer this weekend.
     

Share This Page

Loading...