USB Joypad keeps failing

Discussion in 'Windows 7 Hardware' started by 1Bit, May 10, 2013.

  1. 1Bit

    1Bit Well-Known Member

    Joined:
    Feb 14, 2013
    Messages:
    20
    Likes Received:
    0
    I have the following USB devices:

    USB Joypad
    Sony Miro Xperia mobile phone
    Wireless Transceiver for Keyboard and Mouse

    these are all in USB 2.0 ports.

    I ran a program called DSL stats that I have used before but was a new version, when I ran it there was some odd behaviour and the screen logged out (went black like it does when you log out) a pause, then the ding-dong and logged back in where it said USB device failed and my wifi had been disconnected and reconnected too...

    I looked in DevMgr and noticed me Xperia Miro and USB Joypad were no longer working, no matter what I did I could not get them working again, the only way I could was to uninstall device, remove device, turn off PC, turn off Power, turn on Power, log into windows, plug device into different USB port and it would install... the Xperia Miro has stayed installed but as soon as I reboot the computer the USB JoyPad fail again...error code 43, if I uninstall it, force check for hardware changes and re-install...it will reboot, login and start to install the driver and say it was successfull but devmgr shows that its not (error code 43).

    I even restored the computer to before I run this new version of DSL Stats but no avail, I had also installed Avast Internet Security the night before and think it may have been related as DSL stats runs perfectly nowive removed Avast IS.

    just for info: DSL Stats is a router stats program made by Roseway on Kitz forums, its great and suggest anyone into that stuff to try it, its better than DMT Tool

    so can anyone help me repair this corrupt USB driver that windows keeps installing?

    Windows 7 64-Bit - Gigabyte H77M-D3H - 8Gb Ram - Core-i5 ivy bridge

    thanks
     
    #1 1Bit, May 10, 2013
    Last edited: May 10, 2013
  2. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    I would try the pad on another machine and see what happens. What is the make and model number of the USB pad? Are you sure it has 64-bit driver support?
     
  3. 1Bit

    1Bit Well-Known Member

    Joined:
    Feb 14, 2013
    Messages:
    20
    Likes Received:
    0
    the joypad has worked fine for years previously - it was just when i ran this DSLstats program with Avast IS installed that it went to crap

    ive managed to get it working again just by repeating what ive already done and putting it back into the 1st port it was in..
     
  4. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    Great! Glad you got it sorted out and thanks for the update.
     
  5. 1Bit

    1Bit Well-Known Member

    Joined:
    Feb 14, 2013
    Messages:
    20
    Likes Received:
    0
    ive a feeling i may be back though hehe - once I reboot (I tend to use sleep or leave it on as I have router monitoring stuff running)
     
  6. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    Yeah, but that "should" not be a problem. I rarely shut down or reboot, instead, I just let my systems go to sleep. I last rebooted May 5th and only because an update forced it.
     

Share This Page

Loading...