USB mass storage code 10

Discussion in 'Windows 7 Hardware' started by Georgezx9, May 1, 2011.

  1. Georgezx9

    Georgezx9 New Member

    Joined:
    May 1, 2011
    Messages:
    6
    Likes Received:
    0
    Well, this is really doing my head in, its about time microsoft sorted it out, as many people have the same issue:
    I have tried restoring to an earlier state, but my computer doesnt have any.

    MSCONFIF/Tools trouble shoot computer problems/hardware and sound/configure devices satates that ther is a problem with the driver for my mass storage device.
    My problem, is that my windows 7 pro x64, no longer reads my usb memory card reader OR will it find my Canon EOS digital camera, ocassionally it will see it in explorer, but when you click on it to open it up, it takes hours and nothing happens.

    The USB port works well with USB mice and WIFI dongles, I have tried uninstalling drivers and switching off and then on, all as per other forums but nothing.
    Windowas explorer/computer/device manager shows USB mass storage device as a yellow exclamation mark. When I click update driver it says it is up to date.
    Under properties it states This device cannot start. (Code 10). If I uninstall it or disable and force it to look for new drivers by rebooting, the same. It states that it is using port Port_#0002.Hub_#0009
    The driver being used is USBSTOR.sys

    If I type MSCONFIg at the cmd prompt

    I have tried switching off firewall and virus as well.

    Microsoft recognise the problem and tell you how to fix it as given in Microsoft KB 943104, this tells you to delete two items in the registry, surprise surprise my system wont let me delete the items and its is due to null items being in the registry, microsoft recognise this as well so give a program Regdelnul to delet the null items and replace them by '*', but hey ho the program does not work, it flashes up onto the screen and disapears, is it 64 bit compatable.

    Help!!!!
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Unplug all your USB devices. The USB drivers are normally on the chipset drivers for your system. Have you found any you might be able to download? You don't give any info on your system, so we cannot check for you.

    Have you looked for any specific drivers for the camera or the Mass Storage Device?

    Have you done any cold boots lately?
     
  3. Georgezx9

    Georgezx9 New Member

    Joined:
    May 1, 2011
    Messages:
    6
    Likes Received:
    0
    Got it sorted and what a job!, unplugging and rebooting etc did not work, updating chipset drivers did not work.

    However in my device manager, I had lits of instances of root hubs and universal host controllers.

    Noting that my PC has two USB on the fron and two on the back, my device manager suggested I had about 16,

    By examining the instance it could state whether it was a mouse or a wifi that was connected (dont disable these ones), but if I disabled some of the others the window showing a connection of the USB storage card or my camera popped up.

    Anyone care to mention why this happened, or how I can permanently get rid of them?

    Thanjks
     
  4. Georgezx9

    Georgezx9 New Member

    Joined:
    May 1, 2011
    Messages:
    6
    Likes Received:
    0
    Following on from my comment, whats the difference between a generic usb hub a USB root hub and intel family usb host controller No xxx and a usb mass storage device?

    As stated I have four (not two!) USB at the back, and two in the front.

    In the front I have two things plugged in a USB 1 into 4 USB splitter, into one of these I have a USB card reader and also a USB WIFI dongle.

    In the back I have a USB printer a USB mouse and a USB keyboard.

    Perhaps for others this may explain it better.

    GY
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    What device manager is saying may look different because of all the USB devices. You probably have 6 Controllers and 6 Root Hubs as basic devices. Some of the Controllers may show as "Enhanced". So some of the ports may be USB 1.1 and some USB 2.0. Do you have any USB 2.0 devices?

    Is the USB splitter powered?
     

Share This Page

Loading...