USB ports actiing strangely

Discussion in 'Windows 7 Help and Support' started by artoo, Jul 24, 2012.

  1. artoo

    artoo Senior Member

    Joined:
    Nov 10, 2009
    Messages:
    19
    Likes Received:
    0
    Hi all,

    Just wondering if anyone has any suggestions on troubleshooting a strange problem that occurs when I plug a Segate USB protable HD into any of the USB ports on my computer. From time to time when I plug it in, after a few seconds I get a dialog box saying that the drive is not formatted and asks if I want to format it, even though it has a bunch of programs and data on it. I unplug it and wait a while before plunging it back in and I'm usually able to access the programs and data on the drive.

    Thanks
     
  2. alberto

    alberto New Member

    Joined:
    May 31, 2012
    Messages:
    248
    Likes Received:
    1
    Hi artoo, first thing I'd suggest is make a backup of everything on the drive FAST!
    Is the HD a self-contained unit or is it an internal SATA or IDE disk in an enclosure?
     
  3. artoo

    artoo Senior Member

    Joined:
    Nov 10, 2009
    Messages:
    19
    Likes Received:
    0
    the HD is a elf-contained unit and I don't seem to have this problem with other computers that I've tried. I recently had to do a re-installation of Windows when my internal HD crashed. I was starting to have this problem before that crash.
     
  4. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Check your USB drivers. Uninstall - re-install. It should do the trick. If it doesn't help, it may be a hardware problem, either with your motherboard or the USB gadget.
     

Share This Page

Loading...