USB Power switches off when PC goes to sleep.

Discussion in 'Windows 7 Hardware' started by Steve55555, Oct 1, 2010.

  1. Steve55555

    Steve55555 New Member

    Joined:
    Sep 30, 2010
    Messages:
    6
    Likes Received:
    0
    Hi

    Why, and how can I prevent it, does the power to USB devices go off when the PC is in power save mode (ie goes to sleep ) - even though all the usb controllers are set to not allow the pc to turn off the usb, (box unchecked) and the usb selective suspend mode in advanced power settings is set to disabled.

    (This is to charge an ipod overnight, but without everything on).
    (I have seen other posts where the problem is the reverse: namely they can't switch it off. But my problem is that I want USB power to be on.)

    Windows 7 Professional, HP-Compaq Pentium 4 PC.

    I hope it's something simple and obviious.

    Thanks in advance
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hey, welcome.

    You'll want to install the latest bios for your motherboard and also the latest On/Off Charge utility software for your motherboard, both from the manufacturer's site. Without this, you'll likely run into troubles in the future because this is fairly new and does cause crashes a lot. Updates help.

    Then open device manager. Double click on the Universal Serial Bus controllers section to expand it. For all of your USB Root Hub entries shown, right click on them and choose properties, then power management tab. Uncheck the box to "Allow the computer to turn off this device to save power".
     
  3. Steve55555

    Steve55555 New Member

    Joined:
    Sep 30, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks TorrentG

    As stated, I already have the "Allow the computer to turn off this device to save power" boxes unchecked.
    I will go and update the BIOS and On/Off Charge utility software and report back.

    Regards

    Steve

     
  4. Steve55555

    Steve55555 New Member

    Joined:
    Sep 30, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks TorrentG

    You were right. Upgrading the BIOS did the trick.

    Many thanks for a great and quick reply.

    Much appreciated.

    Regards

    Steve
     
  5. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    lol I laughed at myself for the reply because sometimes I read only what I want to see lol lol.

    So I didn't really catch what you said well in the OP.

    Very glad that I somehow helped a little though.

    Enjoy! You're welcome.
     

Share This Page

Loading...