USB Sound Level Is Way Too High

Discussion in 'Windows 7 Help and Support' started by patlaw, Feb 21, 2011.

  1. patlaw

    patlaw Honorable Member

    Joined:
    Oct 22, 2009
    Messages:
    15
    Likes Received:
    0
    We use Vidblaster to broadcast audio and video over Ustream.tv. The software has worked fairly well on our XP SP3 computer. Recently we replaced the host computer that has Windows 7. Everything video wise is working perfectly. The audio for the feed is provided by a Behringer audio mixer over USB (48kHz, 16-bit, stereo). The connection is exactly the same one that we used with the XP computer with zero issues. On the Windows 7 computer, the audio input is WAY too hot. The volume slider on the audio input to Vidblaster has to be set to almost zero. If the slider is moved up at all, the audio level slams the meter and reaches DFS (digital full scale), which means severe distortion.

    To explain the problem in excruciating detail, if the audio were being fed to the Vidblaster computer analog, it would be the same if we were feed a line level output on the Behringer mixer to a microphone level input on the Vidblaster sound card. (In this situations, even with Mic Boost disabled, the incoming audio is very hot.) So, the audio coming from the mixer to the computer over the USB port is too hot.

    The problem is not the mixer. We can connect the USB port to any of three other computers, and the audio level over the USB port is perfect. Once we connect it to the Vidblaster computer, the audio is very much overdriven. The problem is not Vidblaster because we get the same overdriven audio when we use the USB port for audio input for Skype on that same computer.

    There are no special drivers for the Behringer console. It uses the standard Windows7 drivers, which install automatically when the Behringer mixer is connected to the Vidblaster computer.

    Is there a setting or a configuration that we are missing? It seems that there is a setting that the USB audio could be designated as line level instead of mic level, the problem would be solved.
     
  2. patlaw

    patlaw Honorable Member

    Joined:
    Oct 22, 2009
    Messages:
    15
    Likes Received:
    0
    Problem solved. Behringer had an ASIO sound driver for the USB port. When we installed the new driver, moved the USB cable to a new port, and then switched to audio to that device, the problem cleared. A search on the Internet reveals that quite a few people have had this problem. Hopefully this post will help them solve theirs quickly.
     

Share This Page

Loading...