User Account Control

Discussion in 'Windows Vista Help and Support' started by phaneendar, Aug 10, 2007.

  1. phaneendar

    phaneendar New Member

    Joined:
    Aug 9, 2007
    Messages:
    8
    Likes Received:
    0
    Hi guys,
    I'm using windows VIsta Home Premium. I installed my application on this Vista system with administrative privleges(i.e right click on setup.exe & select run as asministrator). After the application is installed i've set the properties of the application as run as administrator(i.e go to the directory where the application is installed rignt click on xyx.exe properties, go to compatibality tab and in privlages field chek Run this program as an administrator).

    Now the problem is when i run the application always an UAC dialog appears saying that "An unidentified program wants access to your computer."

    Can any one suggest how to supress/avoid this dialog.

    Thanks in advance
    phani
     
  2. g6672D

    g6672D New Member

    Joined:
    Dec 22, 2006
    Messages:
    44
    Likes Received:
    0
    Unfortunately, I don't think you can bypass UAC for specific applications. If admin privs are needed, you will have to manually elevate it. You could turn UAC off completely, but doing that is a bad idea. You learn to live with it anyway.

    But if you really want it gone, you can turn UAC off in User Accounts.
     
  3. phaneendar

    phaneendar New Member

    Joined:
    Aug 9, 2007
    Messages:
    8
    Likes Received:
    0
    Hi
    Thanks for your reply. I've read some article that we can turn off this message box by disabling some field in Local security Policies. But i'm unable to get the local security policies in Vista Home Premium. Can you help me in getting the local security policies in Vista Home Premium.
     
  4. g6672D

    g6672D New Member

    Joined:
    Dec 22, 2006
    Messages:
    44
    Likes Received:
    0
    Not recommended, but here's how.

    Go to the Start Orb and type "Local Security Policy" into the search box. Permit. Go to Local Policies->Security Options, find the item named "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" (long isn't it?) and set it to "Elevate without prompting". Done.
     
  5. phaneendar

    phaneendar New Member

    Joined:
    Aug 9, 2007
    Messages:
    8
    Likes Received:
    0
    hi
    I'm not able to get the local security policy for vista home premium. Can you suggest me where can i get the local security policy. I've read that in Vista home premium this security policy is disabled by default.
     

Share This Page

Loading...