Veracrypt Corrupted UEFI


Senior Member
Jan 28, 2020
Asus 2012 UEFI 16GBDDR3 Laptop N56V(z)
Veracrypt version from april 2023
Win10 22H2 Pro
Encrypted C Windows system partition, then deleted all partitions on disk, then in UEFI, removed Veracrypt boot entry option. It never booted since then. It is always black screen, 100% black, nothing else for even 1 second. The HDMI to external monitor is black too. No other recent changes or damage.
I have tried removing battery, holding power button for 30 seconds. Downloaded UEFI EC update, extracted file, put onto MBR FAT32 32GB USB 3.0, had no effect.
Asus made it as difficult as possible to remove CMOS battery, I won't forget that when buying a laptop in the future, CMOS battery removal did not have any affect.
Removed RAM.
What are the next troubleshooting steps?
Last edited:
I have seen a simpler issue a couple times. Had to pull the drive and just format (no need to install anything) the drive from another computer.
It doesn't let me edit the original post. Here is a rewrite, clarifying parts, and adding info.

Asus 2012 UEFI 16GB DDR3 Laptop N56V(z)
Veracrypt version 1.25.9
Win10 22H2 Pro UEFI non-CSM GPT 2.5” SSD
PC and it’s display worked well for the last 1-2 years, until I was in the UEFI, and saw the boot menu list, with a Veracrypt boot entry option, and removed it, after exiting UEFI, screen permanently black. It is always 100% black, nothing else for even 1 second.
The Veracrypt boot option was put there when I had encrypted C Windows system partition with Veracrypt. The encryption was successful, and worked well. After that, I booted to WinPE USB, and purposefully cleaned entire disk of all partitions, including EFI, MSR. No other recent changes or damage.

The disk had no personal files, data recovery or windows recovery is not my goal. I am trying to get the POST, UEFI, or anything to appear on the screen. Normally I can see POST, and I could press F2 for UEFI, or ESC for Temporary Boot Menu, but no buttons do anything now. It is no longer possible to boot to USB stick utility, or DVD utility.

After the black screen issue started, to troubleshot the issue, I have tried removing battery, holding power button for 30 seconds. Downloaded Asus UEFI EC update correct version for this model, extracted file, put onto MBR FAT32 32GB USB 3.0, had no effect. HDMI / VGA to external monitor is black too. Removed RAM. Removed CMOS battery for several minutes. Removed SSD. Performed steps to boot from USB/DVD utility, no effect.

DVD bay works, spins disc. Keyboard lights up, power button lights up when turned on. CPU fan spins when on.

I read in 2 places, that Veracrypt has a super secure blank screen startup mode that can be activated, but I am not aware of having activated that setting.

My goal is to fix the blank screen that happened after removing the Veracrypt boot option in the UEFI setting.

What are the next troubleshooting steps? Thank you.
Any settings or boot entries would be on the disk, hence why I stated format the drive
If your UEFI (Unified Extensible Firmware Interface) is experiencing issues after using VeraCrypt, it's essential to address the situation carefully. Firstly, try to identify the specific problem by determining whether it is related to the VeraCrypt installation or if it's a broader UEFI corruption issue.

  1. Isolate the Problem:Investigate if the UEFI corruption is directly linked to the VeraCrypt installation or if there might be other factors contributing to the issue.
  2. Backup Data:Prioritize data safety by backing up your important files and data. This is crucial before attempting any corrective actions to avoid potential data loss.
  3. Verify VeraCrypt Installation:Ensure that VeraCrypt was installed correctly and is compatible with your system. If there are any known compatibility issues, check for updates or patches from VeraCrypt.
  4. Boot Repair:Attempt to repair the UEFI bootloader using built-in tools or recovery options available on your operating system installation media. This may involve using commands like bootrec for Windows or grub-install for Linux.
  5. Check UEFI Settings:Verify the UEFI settings to ensure that the boot order is correctly configured and that the UEFI firmware is detecting your storage devices.
  6. Update UEFI Firmware:Check if there are any updates available for your motherboard's UEFI firmware. Manufacturers often release updates to address compatibility issues and improve system stability.
  7. Virus/Malware Scan:Perform a thorough virus and malware scan to rule out any malicious software that might be causing UEFI corruption.
  8. Consult Documentation:Refer to the documentation provided by VeraCrypt and your motherboard manufacturer for any specific guidance or known issues related to UEFI compatibility.
  9. Seek Community Support:Visit online forums or communities where users discuss VeraCrypt-related issues. You might find others who have experienced similar problems and have solutions or workarounds.
  10. Professional Assistance:If all else fails, consider seeking assistance from a professional technician or contacting customer support for both VeraCrypt and your motherboard manufacturer.
Top Bottom