Very Slow File Operations- Copying, Deleting

Discussion in 'Windows 7 Help and Support' started by Dave McKeen, Aug 8, 2010.

  1. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    Hello! I am running Windows 7 Home Premium 64 bit. I've been seeing very slow file operations since making this PC my main computer earlier this week. My system specs are listed below my signature. In addition to the specific example below, the problem appeares copying image files from a CF Card (see specs) and to an external USB 2.0-connected hard drive. Interestingly the transfer rate is "lightening fast" between this PC and a PC I use as a NAS over 75" of Cat 5c cable at 23.4 MB/s.

    A specific example: On my data drive (the Hitachi 2TB) when I copy 150 image files (about 729 mb) from one folder to another it takes approximately 27 seconds. When I delete the 150 files from the destination folder it takes about 27 seconds. The drive is about 20% full and has been defragmented recently.

    1. When I boot in Safe Mode the copy takes 4.7 seconds and the delete takes less than a second.

    2. I boot after selecting Selective Startup in msconfig leaving Services normal and disabling all Startup items the original problem persists.

    3. In msconfig I disable all non-Microsoft Services and all Startup items then reboot and the original problem persists.

    I would appreciate suggestions of any further tests or diagnostics I can run to isolate this aggravating problem.

    Thanks - Dave

    CoolerMaster RC-534 KKN2-GP Black Centurion case
    ASUS P7P55 Deluxe
    PC Power & Cooling Silencer 750 Quad 750W, single 60A 12V rail
    Intel Core i7 860
    Corsair CMX8GX3M4A1600C9 (4 sticks x 2GB)
    ZOTAC ZT-98GES3M-FSL GeForce 9800 GT 512MB 256-bit GDDR3 PCI Express 2.0 x16
    nVidia Driver (as of 27 August 2010) 8.17.12.5896
    Drive0 (OS) OCZ SSD Vertex 2 OCZSSD2-2VTX50G 50GB
    Drive1 HITACHI UltraStar A7K2000 0F10452 2TB 7200 RPM 32MB Cache SATA 3.0Gb/s
    Drive2 (Apps, pagefile, misc.) OCZ SSD Vertex 2 OCZSSD2-2VTX50G 50GB
    1394 board Rosewill RC-502 NEC 3+1 1394a PCI
    1394b board Koutech 4-port 1394a/b PCIe x1
    DVD Drive Plextor PLX-850A-19 IDE S/N 310907400763
    CF Reader FireWire Sandisk Extreme Pro ExpressCard Adapter 1394b (800MB/s)
    CF Card Sandisk Extreme IV 4GB 45MB/s UDMA
    Monitor NEC LCD2190 UXi LCD 'twist' tech.
    Microsoft Windows 7 Home Premium 64 bit
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    When you are in normal mode Windows, try your deleting and copying tests again. Only this time, have the task manager opened. Make sure the cpu time in use is 0% or close to it (less than 10%) when you start the tests.

    Basically...can you confirm that this still happens when the cpu is not or barely being used?

    I dunno. What I'm trying to get at is if there is a service running that may be slowing everything down, such as the Windows Search service. If this is doing any work at all, it would be a reason for the poor performance. I would try disabling this service as a test too.

    You can type services.msc in the start menu to get the screen to do so.
     
  3. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    Hi TorrentG,

    I watched the CPU usage while I ran the example:

    1. Source on HD to CF Card 1 min 18s (Safe Mode was 45s) CPU 6%
    2. CF Card to Dest. Folder 30s (Safe Mode was 5s) CPU 12%
    3. Delete from Dest. Folder 29s (Safe Mode was <1s) CPU 18%

    After all that I looked at the processes. Explorer.exe remained at 13% for several minutes. I'll run it again and watch the processes:

    1. When I went to run this step Windows Explorer disappeared. It vanished! Try again:
    This time explorer.exe was the only process running, taking 4-5% of CPU. CPU usage dropped to zero on completion.

    2. Explorer.exe was the only process using CPU at 13%. CPU usage dropped right off on completion.

    3. Again, explorer.exe was the only process using CPU cycles. It's usage went right to 18%. Toward the end of the operation the usage tapered to 13% then to zero on completion.

    I didn't see how to stop Windows Search in services.msc. I can do it in msconfig. Since I didn't see it taking CPU cycles in Task Manager should I go ahead and repeat everything with it stopped?

    Thanks very much - Dave
     
  4. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hey..

    The only things off the top of my head that would do something like you describe - good in safe mode, not good in normal mode - would be the chipset drivers and antivirus.

    To update your chipset drivers, let Intel's Driver Update utility scan and install. It's in the blue near the top of the page in the following link:

    http://downloadcenter.intel.com/default.aspx?iid=gg_support-EN_01+home_downloadctr

    If that doesn't install any update for any reason, then download the latest chipset driver package from the following link and install:

    ASUSTeK Computer Inc. - Motherboards - P7P55D Deluxe


    ------

    If that doesn't fix it, I would uninstall the current antivirus in safe mode, using the tool found here:

    AV Uninstallers - Windows 7 Forums

    Then boot to normal mode and test it out. If all is well now, then install MSE as a replacement.

    Obviously, if it is still not fixed, then the original antivirus you had installed is not to blame either.
     
  5. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    You got Norton in there?

    Norton (a Symantec product) is known to chew up disk speed by insisting upon virus checking every file that is opened, closed, written or renamed. It's also famous for messing up perfectly safe file moves by refusing to delete the files from the source.

    As a rule, wherever I see Norton I uninstall Norton... Plainly: It's crap.
     
  6. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    TorrentG and Tater- I have MSE on this system. Should I uninstall it and run my tests then reinstall?

    I followed the link to the Intel drivers page. It ran a check and said that I had three components it could not identify that might ir might not need drivers. One was my nVidia card, and the other two were irrevelant. On the Asus site install for the chipset driver reports that the one I"m trying to install is older than what is already installed. (Odd?)

    Am I at a dead end?

    Oh- by the way, I back up my Outlook PST files from my C drive to my D drive every day. My sync program reports the transfer speed as 218 MB/s. Yes, that's 1.55GB in 6 sec. What do we make of that? Actually, that's the kind of performance i've been expecting from this system.

    - Dave
     
  7. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Nope, not dead ended.

    Go to Control Panel -> Device Manager ... You should see a category for unknown devices... that will tell you what you need.

    NVidia drivers are all available directly from NVidia and will most often be newer than the ASUS ones... For the others ... well... google is your friend.

    No driver is irrelevent, they're part of the core functionality of your machine.
     
  8. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    I now have the latest nVidia driver installed. It's 8.17.12.5896 dated 7/9/2010.

    I have the latest drivers for
    Logitech (Setpoint)
    Wacom
    Epson Printer
    Brother Printer
    Korg
    Epson Scanner

    I unchecked Windows FAX and Scan but got an error in Outlook so turned it back on.

    File operations I first reported are still slow. What to make of the extremely fast transfer from my C drive to my D drive? Is there a diagnostic I can run to help narrow down the conflict?

    I've attached the upper part of a Belarc Advisor report in case that would be helpful.

    - Dave
     

    Attached Files:

  9. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    USB is slow to begin with ... It tops out at about 23mbps. but never actually gets there, Moving files from one usb device to another cuts that speed in half as the two devices have to share bandwidth. For example: My flash drives (and I got lots) became noticeably slower when I changed over to a usb mouse and keyboard.

    What bothers me about your report is the difference between user mode and safe mode speeds...
    Something you've got running is trashing your transfer rates....
    It might be Windows Defender or some other anti-virus program, or if you're using special backup software there might be some issues with it. I'd suggest you try disabling all anti-virus, anti-spyware software and using a fresly formatted usb memory card try doing some test transfers and see how that goes...
     
  10. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    I quit using Windows Defender when I kept getting browser freezes.
    Joe
     
  11. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    Hello Tater, I'm running Microsoft Security Essentials and have Windows Defender disabled. Should I uninstall MSE, run my tests and then reinstall the AV program?

    In my example I was moving data between a Sandisk Extreme 4 45MB/s UDMA Compact Flash card Via Sandisk's Extreme reader over 800MB/s 1394b Firewire on a PCIe 2x adapter card and the 2TB Hitachi. Also just copying from one folder on the HD to another then deleting is a repeatable test I've been doing.

    And note the transfer rate between the SSD and the 2TB of over 200 MB/s. And today large backup files went to my NAS at over 50MB/s!

    - Dave
     
  12. CommonTater

    CommonTater New Member

    Joined:
    Jul 21, 2010
    Messages:
    868
    Likes Received:
    36
    Well... disabling MSE and doing some test transfers would tell you if it's slowing things down or not.
     
  13. RCube

    RCube New Member

    Joined:
    Sep 27, 2010
    Messages:
    4
    Likes Received:
    0
    I realize this thread is a bit old but I just solved this issue for myself and felt that some kind of solution should be posted somewhere as there seems to be no definitive fixes for this anywhere.

    @Dave McKeen:
    I have an ASUS G72GX notebook and have been suffering the exact same issues you described, since I purchased the machine. I tried to convince myself it was just residue of Vista screwing up Win7 but when I read your post about safemode file ops working so fast I had to test that for myself. And you were right, they were MUCH faster using the generic safemode drivers. So I followed the link to the Intel Driver Update Utility. Like your test, it did not help me at all. So I began a manual search of the drivers for my chipset. There, at the very bottom of the list was an upgrade for the "Intel Matrix Storage" driver. It handles enhanced file operations for SATA/RAID drives. I installed that and lo-and-behold, my file operations are now screaming fast as I always felt they should be. I copyed several hundred MB of data in just a few seconds. YAY! Problem solved, I can finally stop complaining about how sucky Win7 file ops are. Sorry Windows 7, you now kick quite a bit more ***. Now, just fix the lame file content searching for non indexed files and Win7 will be a total win. (no pun intended)

    @Joe S:
    Windows Defender is the devil. Buy MalwareBytes if you need quality real-time spyware protection. If you dont need real-time protection, then the free version works flawlessly.

    Hope this helps someone.
     
    #13 RCube, Sep 27, 2010
    Last edited: Sep 27, 2010
  14. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    Hello RCube, thanks for sharing that! Amazing! Could you post the URL that has the "Intel Matrix Storage" driver in case we can't find it readily?

    - Dave
     
  15. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
  16. RCube

    RCube New Member

    Joined:
    Sep 27, 2010
    Messages:
    4
    Likes Received:
    0
    Yes, that's where I got my drivers. If you go to http://downloadcenter.intel.com/Default.aspx you can use the select boxes to locate your specific chipset.

    Best of luck man, I know your suffering and wouldn't wish it on anyone... well?... nah.. nevermind *evil grin*
     
    #16 RCube, Sep 27, 2010
    Last edited: Sep 27, 2010
  17. Dave McKeen

    Dave McKeen Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    90
    Likes Received:
    0
    I'm at a dead end. I'm a terrible sleuth. I downloaded ChipUtil325.exe and I can't run it. Must be run as administrator. Which I am. Don't see anything about a Matrix Storage Manager driver for P55 on Intel site. :( Close, but no cigar...

    [edit]
    Did a search on Intel's site on P55 and got this:
    http://www.intel.com/Products/Desktop/Chipsets/P55/P55-tools.htm

    On the above page is a Tools and Softwate tab with a "BIOS and driver updates" that got me this:
    http://www.intel.com/support/chipsets/sb/CS-029901.htm

    The bottom row of the table has IntelĀ® Rapid Storage Technology for the P55. I will look into it in the morning!
     
    #17 Dave McKeen, Sep 27, 2010
    Last edited: Sep 27, 2010

Share This Page

Loading...