Viewing XP network

#1
Hi

I have tried to find a solution, but so far all answers have drawn a blank.
We have add a Windows 7 PC to a network with a couple of XP computers. My problem is viewing the XP PC's. The only way I can get it to work is to go to my Network Connections on th W7 PC, right click on the Local Area Connection and disable it. then right click and enable it again.

This works fine, I can map network drives, share data, print on other PC's etc. As soon as I turn off the W7 PC again and restart, it can't see any computer on the network (inc itself). Go and disable and enable as before and it works.

Any ideas?

Network discovery is on
File and print sharing is on
All are on the same workgroup, same IP range etc

Thanks in advance

Andrew
 


Trouble

Noob Whisperer
#2
wildtrekker:
Hello and welcome to the forums. If you would please fill out your system specs in your forum profile that will helps us better provide some useful information.
Is this machine wired or wireless, do you have the latest driver for the network adapter installed from the adapter manufacturer's website, or failing that at least from the PC manufacturer's website.
When you reboot the PC and your XP machines are not showing up, can you still get on the internet, can you still ping the other machines by ip address and or netbios name, before you go through the disable enable routine. While the computer is not showing the other machine can you do an ipconfig /all to make sure that it is getting DHCP information?
Please provide if possible the Manufacturer, model name, model number, version number information for your network adapter.
 


#3
Hi

The PC is wired and is new, with win 7 preinstalled on it.
Yes, I can brows the internet, but pinging the other machines just times out. All the DHCP info is getting through too.

It's a Medion E4355 D (MD 8341)

It's almost like it can't browse any PC on the network, including it's self

Cheers
 


Trouble

Noob Whisperer
#4
right click on the taskbar and choose start task manager, choose the processes tab, click the box near the bottom that says show processes for all users. Do you see anything call mdnsresponder running.
Type services.msc into the search box and hit enter, maximize the services management console and look for a weird string near the top something like this "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##" if it's there double click it and choose stop and in the startup type change to disable. Also look for something called Bonjour do the same thing. While in services check and make sure that the Computer Browser service is started and set to automatic as well as the TCP/IP NetBIOS helper services. Check the properties of IPv4 in you network adapter properties and make sure that enable NetBIOS over TCP/IP is selected.
 


#5
hi, thanks again for your reply

mdnsresponder was not running.
No string like "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##"
Nothing called Bonjour
Computer Browser service had started, but set to manual, so changed to automatic
TCP/IP NetBIOS helper services was runing and set to automatic
enable NetBIOS over TCP/IP was not selected, but now is

Have rebooted but still the same. Only difference is I can Ping the other computers IP addresses, but if I try and browes the networ, it shows "0 items"
 


Trouble

Noob Whisperer
#6
disable ipv6 in the properties of the network adapter on the windows 7 machine
try flushing the DNS cache....command prompt, ipconfig /flushdns all machines
try flushing the netbios cache...command prompt, nbtstat -R alll machines
confirm netbios cache is empty....command prompt nbtstat -c shouldn't contain any entries
make sure there are not machine name conflicts...each machine's netbios name is unique
ping all machines from each to each by ipaddress and then netbios name all machines (then recheck the netbios information on each machine command prompt nbtstat -c make sure the machines are correctly identified by name and proper ip address.
if either of these two processes fail, then take a look at what security products are running on the individual machines, make sure you either know how to tweak the product and it's respective networking trust applet or uninstall temporarily to make sure that is not causing the problem.
Check the router manufacturer for a firmware update also check the router interface for something called UPnp (Universal Plug and Play) if it's not enabled try enabling it.
See if you can actually identify the network adapters chipset manufactuer and see if there is a driver update from the manufacturer.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.