Vista Business cannot connect into win 7


Setup is other PC use a username and password to access user C:\Users\Public\Folder. I have no issues when win 7 PC connect. I can see the win 7 machine in workgroup network and am able to ping the win 7. However Vista PC throws out the basic Access denied.

Thanks in advance for your help.


Excellent Member
Microsoft Community Contributor
There is an option for Public Folder sharing in the Advanced Sharing settings. I suppose you have that set to allow sharing?

Also you might look at the Password protected sharing option.

And of course these options are located in the Network and Sharing Center, upper left.


At the current time I have 3 other PC (runnng win 7) able to access the folder. The only difference between those that are "Able" and those that are "Unable" is the "Unable" is running Vista Business. Would the OS Vista have special settings that are required?



Noob Whisperer
Hello and welcome to the forum.
This type of problem is usually a result of some type of third party software present on the network (either on the computers involved or possibly even on the router or other network appliance) that is preventing access. So you need to first examine anything like that running anywhere on your network nodes and make sure that all necessary network machines are included and "Trusted".
Could be any thing like a third party firewall product like Comodo or ZoneAlarm, or any of a number of third party software security suites that install firewall like applets and or network filters on top of your normal adapter components.
There is one other strange thing I have seen associated with a Vista when accessing some folders on a Windows 7 share, but this is generally associated with system folders, like the print spooler folder, but you might try this and see if it works for you, easily changed back to previous settings if it doesn't help;
Right click the Windows 7 shared folder you are having trouble with and choose properties
Now under the Security Tab
Click the Edit button under the top frame
In the next dialog box that appears select the add button
In the next dialog box that appears select advanced button
In the next dialog box the appears select the find now button
In the bottom frame choose "NETWORK" and click OK
then click OK again on the box that you go back to
And then on the next box you go back to click to select "NETWORK" which you just added in the top frame
And check the box for full control under the allow column in the bottom frame
You will probably get a security warning, just click yes
And then you'll go back to the properties box, just click close.
You may have to reboot, not sure. Won't hurt

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.