Vista Home Premium + RAID 0 = noboot?

Discussion in 'Windows Vista Installation' started by effigy3, Dec 1, 2008.

  1. effigy3

    effigy3 New Member

    Dec 1, 2008
    Likes Received:
    My system:
    AMD Athlon X2 6000+
    Asus Crosshair (nForce 590 chipset) motherboard
    (2) WD Raptor 75GB HDD in RAID 0 running off the nVidia RAID controller
    Seagate 500GB SATA HDD (was D:/ for My Documents on my XP Pro setup)
    8GB of Kingston HyperX RAM (in XP Pro 32 bit it naturally displayed only 3-ish GB but in BIOS all 8 reported)
    Asus Radeon HD4870 video card
    Creative X-Fi Fatality Xtreme Gamer Pro edition (PCI)
    (2) DVD drives
    Floppy drive

    Attempt 1:
    I used my Partition Commander v8 program (by Vconn) to delete and reformat the RAID array drive as NTFS. During boot the array POSTed as “healthy”. I booted off the Vista CD and the installer recognized the RAID array as a single drive and associated it with C:/ The Seagate drive was D:/ Installation proceeded smoothly, no RAID drivers necessary. I installed all my motherboard and peripheral drivers just fine using my 2nd optical drive. There were a total of 3 reboots during driver installation. When I finally removed the Vista install media and tried to reboot I got a “non system disk” error. I could only boot up if the CD were in the first optical drive. I triple checked
    that the BIOS had my RAID array HDD as the first HDD listed and that the boot order was HDD first, CD second yet I could not boot my system sans Vista installation media.

    Attempt 2:
    I used Partition Commander to delete the partition on the RAID array disc. I went into the RAID software at boot and rebuilt the RAID array from scratch. I installed the 3 RAID drivers (the newest drivers were diligently downloaded to my thumb drive) during Vista installation when I was prompted. Vista detected the array just fine and reported it as unpartitioned space as it should. I let Vista format the C:/ this time and installation proceeded smoothly. Once the basic install of Vista had completed I removed the installation media before I installed any drivers and did a reboot. I was again presented with a “non system disk” error. If I reinserted the Vista CD I could boot.

    Attempt 3-5:
    I tried various combinations of formatting and BIOS structuring. All with the same results. I could get Vista installed to the RAID array but I could not get it to boot off the RAID array. One irritating fact was that with each successive reinstallation attempt I would add another “dummy” Vista OS listed at boot. Considering I was wiping the “C:/” clean between each install attempt I don't know where this was being tracked. XP never had such problems.

    Current condition:
    I have disconnected both my Raptors and have installed Vista to my Seagate drive. It works fine but I have this RAID 0 array that has worked in XP Pro for 2 years sitting un-powered in my case because Vista refuses to boot from it.

    Any ideas?
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Aug 28, 2007
    Likes Received:
    Hi effigy3,
    welcome to the forum..:)

    First of all, thankyou for providing all the detail concerning your problem, it really is a great help.
    The thing is I can't understand why vista is not picking up the array once the install has completed especially when the system needs to reboot during the install.
    I run a RAID set-up and have used a Nforce system so I know that they are fairly straight forward to use... In fact I'm pretty sure vista should see the array by default as vista is more RAID friendly than XP (apparently....?) I know when I ran an nforce board vista would see the array no problem and I could've ran it without installing the drivers but anyway I digress..

    The only thing I can think of trying is...
    Check the jumper settings on the drives (if the have them) Check this thread out:
    Windows Xp on Raid 0 will only boot when...
    and this one:
    windows vista general Vista Ultimate will not boot without CD\DVD
    Removing all HDDs apart from the drives used for RAID. Then rebuild a new array and totally wipe off all those extra copies of vista.
    Set the boot order to boot from disk and install vista to the RAID array using the drivers if prompted. During the install when the first reboot happens quickly nip into the bios and change the boot order back to boot from HDD first.
    Good luck!
    Please post back if you need any more help...:)

Share This Page