Vista Keyboard Laptop Problem.

#1
Last night I received an Christmas Email from someone I knew. Since opening it my keyboard hasn't worked properly. It seems to be a spyware problem, but I can't seem to remove it as Spybot doesn't seem to think their is any problem with my Laptop. (Although the person who sent it to me hasn't encountered any problems, and neither has the people they sent it too. Although I think they all run XP).

The keyboard doesn't display the correct charcters. When I press a s d f j k l they are the only letters that work. If I press any key along the QWERTY line I get ^Q ^W ^E ^R ^T ^Y ^U ^O ^P the i key doesn't do anything.

The only way I can get round this problem to type is press and hold one of the letters that works, then any other key I press works fine, but I can't go around holding one key down all the time, also I have to delete that character as well.

Does anyone have an idea how to fix this? I've tried restore from a previous date, and that didn't work. I'm pretty knowledgable when it comes to PC, as I build my own, but this problem has stumped me. It took me an hour to work out the workaround of holding a working key down.

I'm assuming it's a spyware problem as my browser will not allow me to access spybot home page, neither will it allow me to update through the application. I'm about to try and download the latest update on this machine, and transfer it to my laptop using USB. If that solves the problem then I'll post.
 


#2
Further investigation.
I've was able to get the new version of spybot on my laptop. Didn't find anything.

I was able to get into the BIOS of my laptop and my keyboard seems to be behaving incorrectly in there too. Of course there is no where I can type text, but it bleeps alot and doesn't do anything on certain keys.

I've loaded Windows up in safe mode with a command prompt, but it's still doing the same thing.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
#3
Hmm.....weird one... You could try loading up AVG anti virus and seeing if that finds anything ?? It may be worth a try..
 


#4
Hi.
Thanks for the reply. I already have AVG installed and fully updated. I ran a full system scan and it found nothing.
I've also connected a USB keyboard to my laptop. The same thing happens. ^P instead of p. The ^ symbol must be the code symbol for the Ctrl key. Because if I have notepad open and just press P key it opens up the print dialog box.

I'm gonna try and attempt to re-install the bios, or get a new bios if one is out for my laptop.

But I'm still open to ideas.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top