Vista SP1 drivers not working for Delta under Win 7

Discussion in 'Windows 7 Hardware' started by mrkode, Jan 21, 2009.

  1. mrkode

    mrkode New Member

    Joined:
    Jan 21, 2009
    Messages:
    6
    Likes Received:
    0
    Intel dual core 6300 @ 1.86
    Windows 7

    Not recognizing my M-Audio Delta 44 sound card upon install. Went and downloaded the drivers on M-Audio's website, tried with the Vista and then the Vista (SP1) but everytime it tells me that it's not supported.

    Is there a way around this?

    Thanks
     
  2. djwayne

    djwayne New Member

    Joined:
    Jan 14, 2009
    Messages:
    874
    Likes Received:
    27
    Yes. I have the M-Audio Delta 1010LT which has similar if not the same driver. Right click on your driver set up file, and then select "Troubleshoot Compatibility", answer the question, then run the setup with the Vista compatibility checked. This is what I did and the Delta driver loaded right up. I then went into Window's "control panel", then "sounds", selected the 1010LT as my default sound card, and it's been working great ever since.
     
  3. mrkode

    mrkode New Member

    Joined:
    Jan 21, 2009
    Messages:
    6
    Likes Received:
    0

    Thanks a lot man!!!

    It worked.

    Just noticed I have some crackling though.

    Anything to do with Win 7?
     
    #3 mrkode, Jan 21, 2009
    Last edited: Jan 21, 2009
  4. djwayne

    djwayne New Member

    Joined:
    Jan 14, 2009
    Messages:
    874
    Likes Received:
    27
    Fantastic !!

    Now you may have to set up your W7 mixer, you do this by going to your taskbar, look for the speaker icon on the lower right hand side, click on it, and then click on "mixer', then click on your device, and a properties box should open up, click on the "advanced" tab, then select your default format, mine is "10 channel, 24 bit 44,000Hz, (studio quality)" then do the test by clicking on the test button.

    Don't forget to go into the M-Audio mixer and setup your settings as you want them. You can find that by going into the Window's control panel, and look for the M-Audio icon. I set up a shortcut to it, and pinned it to my taskbar for easy access.

    I had a little bit of crackling at first, but it went away by itself, after being used for a short while.

    I went into my M-Audio control panel, selected the "Hardware" tab, and changed my soundcard's sample rate to 96,000Hz. Now 96,000 Hz is my default setting in the W7 mixer.
     
    #4 djwayne, Jan 22, 2009
    Last edited: Jan 22, 2009
  5. mrkode

    mrkode New Member

    Joined:
    Jan 21, 2009
    Messages:
    6
    Likes Received:
    0

    Ok I'll try that.

    In the meantime, since you have a music production card, you might also have a music production software so I'll try another question.

    When trying to open Cubase essential 4, I get the message :

    Device: Multichannel (M-Audio Delta 44)
    Errorcode: FFA-5-0044 [88780064]

    info

    Device could not be opened.

    Any idea what could cause this?
     
  6. djwayne

    djwayne New Member

    Joined:
    Jan 14, 2009
    Messages:
    874
    Likes Received:
    27
    No, I don't have a clue....I don't have Cubase, I have Adobe Audition 3.01 and Sonar Home Studio 6XL, and both programs are working great on my machine. I have heard of some people having problems with the 64 bit version of Windows 7 with Audition....I'm running the 32 bit version for program compatibility.
     

Share This Page

Loading...