Windows 7 w7 and fsx headaches

Discussion in 'Windows Games' started by camtech, Mar 11, 2010.

  1. camtech

    camtech New Member

    Joined:
    Mar 11, 2010
    Messages:
    8
    Likes Received:
    0
    Well you good folks out there I have a problem with w7 and fsx.
    I have been running fsx on xp pro 64 for about a couple of years and it has done well concidering with all of the add ons.

    I like many decided to upgrade to the new and latest system w7, and I heard good results.

    I went out and got the w7 64 ultimate, and loaded it with little effort, and then loaded fsx and loaded all of the latest sp1, sp2, and I loaded them in the correct way.

    This graphics card does not meet minimum
    requirements for shader support. This product requires a geForce3/Radeon8500
    class or better graphics card. Flight Simulator will now exit."


    Also with sp1 I was able to get into fsx and choose setting and adjust a few sections, I also was able to choose a default 172, my frame rate (57 fps) was never that high before with xp (32 fps) with all the fixings.

    Then within a minute the sim would freeze and act sluggish and respond slowly and the counter is frozen at 52 fps.

    I will have to exit or three fingers it and restart the computer.

    I then would load sp2 and then restart the computer and then it gives me this ridiculous error
    I have used cleaners to get old vid drivers out and the whole clean install process.

    And for some reason I cannot get fsx to play on my system, I have tried every thing possible to get it to work.

    My system = Intel e8500 dual core, 4 gigs ddr3, 280 HD, gtx.285 vid card.

    I know this machine can handle fsx, I know of systems with the same chip and vid card with great success.

    So I guess the question is fsx compatible to what I got , I do remember that when W7 was in its beta stage I tested fsx on w7 32 bit and it worked great, also tried it in the beta 64 bit and it worked but I did not have enough support drivers so I stayed with w732.

    But for some reason I cannot get it to work right on a boxed version of w7 64.

    Are there proper procedures that im missing?

    I have reloaded and formatted my drive several times.

    So I need some real technical assistance on what and why it won’t work.

    Thanks………………………..Robert
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,841
    Likes Received:
    1,568
    Hi Robert,
    I'm not actually familiar with the sim in question but wondered if you'd tried running it in 'compatibility mode'?
     
  3. camtech

    camtech New Member

    Joined:
    Mar 11, 2010
    Messages:
    8
    Likes Received:
    0
    im not for sure i follow you when you say capatability mode.

    Thanks.............Robert
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,841
    Likes Received:
    1,568
    If you rightclick on the games start up icon and then choose properties, you'll see along the top 'compatibility', click that. You'll then see options to run the game as if it was running under a different os like XP for example. See the screenshot for further details. (I've used my supreme commander2 icon for the example)

    View attachment 5674
     

Share This Page

Loading...