W7 not assigning drive letter upon startup (Non OS storage drive)

Discussion in 'Windows 7 Help and Support' started by Logan Hunt, Aug 15, 2010.

  1. Logan Hunt

    Logan Hunt New Member

    Aug 15, 2010
    Likes Received:
    Hello everyone, I will cut straight to the chase:

    I have two raid arrays, one stripe (OS) and one span (or JBOD, which is where I store data). The problem I am having is Windows will not automatically assign my data drive a drive letter upon starting up the computer. I have to manually go into disk manager and assign one every time. I have done everything I know to fix this. I have reformatted multiple times - on a fresh install of windows, it still does it. I have deleted the array, recreated it and formatted it NTFS - still no luck.

    I will provide some information below in the form of screen shots. I thank you in advance for taking the time to read my problem.

    Imageshack - msinfo32.png

    nVidia Control Panel/My Computer/Drive Manager:
    Imageshack - hdproblems.png

    Also, while I'm thinking about it, I have not tried doing a mobo firmware or bio flash or anything like that...maybe that's what it needs?

    MSI NF980-G65
    Newegg.com - MSI NF980-G65 AM3 NVIDIA nForce 980a SLI HDMI ATX AMD Motherboard

    Additionally, plugging in external hard drives and flash drives work fine - W7 assigns drive letters to them.

Share This Page