W7 Realtek HD audio - no custom equalizaer any more

#1
Hi all
I'm REALLY disappointed with the W7 Realtek HD audio driver (V 2.33) as you can't control the equalisation any more. There's a load of "Canned presets" which I don't really like but no way to use a custom equalisation scheme like there was in XP.

Seems to me a retrograde step -- the Engine is obviously there as you've got these zillions of preset options - but I really MISS the ability to use the equaliser to be able to set my own sound settings.

Here's what I mean I enclose screendumps of the XP driver and the latest W7 one (works on both x-86 and x-64).


Cheers

jimbo
 


Last edited:
#2
Be patient. This is a Realtek problem, not a 7 problem. They need to implement it in the drivers.
Wait for Realtek to get their shite together.
 


stueycaster

Millennium Celebration Award Winner
Premium Supporter
#3
I was able to get an updated driver for my onboard Realtek AC'97 sound card at the Realtek site. I didn't have any "Environment' controls before. They were grayed out. It works fine now. Maybe there is something there for your Realtek HD.
 


#4
Yeah,, I should have mentioned going here to get the drivers.
If you got them from Windows Install or Windows Updates.
Uninstall them and go to link above and get them from there.

My previous post still stands however, if there are any problems.
 


#5
Hi there
that link just goes round in circles -- you never actually get to a download site - after you click the NEXT button it presents you with the first screen again.

cheers
jimbo
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#6
Try this jimbo: Realtek
 


#7
same again - after you click GO on site 1/2/3 you get back to the original screen to start the whole process all over again.

Express download works but its fiddly as you need to use the FTP with password method.

The driver downloaded is the 2.33 version which is exactly the one I have problems with -- its the one WITHOUT an equalizer setting unlike the XP driver which DID have the feature.

Cheers

jimbo
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#8
I just tried it by clicking on 'Number 1 Go' and it started the download. Which browser do you use?

If it's IE check your active X settings (see screenshot) You can get to them via Internet options, security, and then 'custom level. Go through each setting and either enable or check the box for it to prompt you..
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.