W8 Apps won't install: "Why didn't this app install?" message

Discussion in 'Windows 8 Software' started by bluewing, Mar 3, 2012.

  1. bluewing

    bluewing New Member

    May 30, 2009
    Likes Received:
    Just installed W8 32-bit on an Asus F8P-X1W laptop with Intel I7/ 2 Gb mem + 150 Gb disk.

    The O/S installed perfectly & Windows update works fine. However, when I try to install apps such as "Ashampoo FX", "Finance", "Solitaire", "Maps" etc., the install fails:

    The sequence is:

    Pending => (progress bar gets to about 85% or so) => a question mark in a circle flashes on the screen for a fraction of a second => Message in orange/brown type appears "Why didn't this app install?". Clicking on the message opens a small info box with the message "Something happened and this app couldn't be installed" and two click boxes: "try again" and "cancel".

    ...? how does one go about determining the problem? Are there logfiles or something somewhere?

  2. Trouble

    Trouble Noob Whisperer

    Nov 30, 2009
    Likes Received:
    Hello and welcome to the forum.
    In many instances you may find it necessary to use compatibility mode to get some software applications to successfully install and I suppose in some other instances the software is just not going to work with Windows 8 Consumer Preview.
    But I would definitely right click the installer (setup.exe) and choose properties, select the compatibility tab and choose one of the OS options if you know it worked in Windows 7 then use that as your choice. Additionally just for good measure check the box near the bottom that says run as administrator. See if that gets you over the hump.
  3. OldTimer

    OldTimer Banned

    Jul 19, 2010
    Likes Received:
    I just got through, installing Thunderbird 11 and MS Office 2003 and both installed just fine and both run just fine.
    I installed both from the Desktop. (like where else?)

    So far I've installed about a dozen programs and they have all installed and run just fine.
    I would have installed MS Office 2007 Enterprise, but it's such a piece of crap I didn't want to waste my time with it.
    Office 2003 is sufficient.

  4. Gunny Teufulhund

    Gunny Teufulhund Well-Known Member

    Mar 21, 2012
    Likes Received:
    Hello all. @ bluewing. I am encountering the exact same issue. This is an issue that cannot be addressed by using elevated privileges or compatibility mode. The reason is that these are METRO apps. NOT a regular UTILITY/ software application type items such as Thunderbird or office. I am able to go to the STORE and select apps for download. However, once they are selected they fail to download and install. Whether the failure is the download or the install I haven't been able to determine yet. I highly doubt it is the download portion. And YES I have not only disabled my security (ESET) I have uninstalled ESET and tried again. No Joy. I have also tried to DL and Install from a Microsoft account. Any input or ideas are welcome.

Share This Page