Weekly MEMORY_MANAGEMENT

#1
First of all, sorry if my english is broken.

Since arround a month ago, almost once a week my PC crashes and shows a Memory_Management BSOD error. Usually happens when web browsing or watching a youtube video or a stream. I thought it was some bad drivers or a problem with certain programs, but after a problem with a Trojan forced me to format the entire system, just today i got the same BSOD even when the PC is practically good as new.

It might be a hardware issue, but the fact it usually happens only once per week even after formating is quite bizarre for be a hardware problem.

W7F, CPU-Z, and RAMMon are in the same file
 


Attachments

usasma

Fantastic Member
Microsoft Community Contributor
#2
Start with these hardware diagnostics: Hardware Diagnostics
Run the MemTest86+ for 7 passes since the error is so infrequent
Also, run the Prime 95 test to see if it happens under stress.
Run the other tests as time allows

Only 104 Windows Updates installed. Most systems have 160 or more. Please visit Windows Update and get ALL available updates (it may take several trips to get them all).

SSD's were temperamental when they first came out, but their reliability has improved greatly over the last year or two. There are 2 things that must be checked on systems with BSOD's and SSD's:
1) That the SSD firmware is the latest available for the SSD
2) That the storage controller drivers on the motherboard are the most recent. They must date from late 2012 or later. This is all controllers, not just the one that the SSD is attached to.
You have both Microsoft Security Essentials and ESET running. Only have 1 anti-virus and 1 firewall running at one time. ESET firewall driver dates from April 2009, so I'd get un-install ESET to see if that helps

Please also run the video tests from the Hardware Diagnostics link above - as the memory dump is suggestive of issues w/video memory.

Please update these older drivers. Links are included to assist in looking up the source of the drivers. If unable to find an update, please remove (un-install) the program responsible for that driver. DO NOT manually delete/rename the driver as it may make the system unbootable! :

UCTblHid.sys Wed Jun 10 04:02:35 2009 (4A2F689B)
Wacom PenTablet HID Tablet Port Driver
http://www.carrona.org/drivers/driver.php?id=UCTblHid.sys

PTSimHid.sys Wed Jun 10 04:03:18 2009 (4A2F68C6)
Wacom PenTablet Simulated HID Port Driver
http://www.carrona.org/drivers/driver.php?id=PTSimHid.sys

TClass2k.sys Wed Jun 10 04:03:44 2009 (4A2F68E0)
Wacom PenTablet Tablet Class Driver
http://www.carrona.org/drivers/driver.php?id=TClass2k.sys

PTSimBus.sys Wed Jun 17 22:20:48 2009 (4A39A480)
PenTablet Bus enumerator
http://www.carrona.org/drivers/driver.php?id=PTSimBus.sys

nusb3hub.sys Thu Apr 22 21:34:35 2010 (4BD0F92B)
NEC Electronics USB 3.0 Host Controller Driver (previous BSOD issues with 2010 and earlier versions)
http://www.carrona.org/drivers/driver.php?id=nusb3hub.sys

nusb3xhc.sys Thu Apr 22 21:34:36 2010 (4BD0F92C)
NEC Electronics USB 3.0 Host Controller Driver (previous BSOD issues with 2010 and earlier versions)
http://www.carrona.org/drivers/driver.php?id=nusb3xhc.sys



Analysis:
The following is for informational purposes only.
Code:
[font=lucida console]**************************Tue Apr 30 00:24:29.373 2013 (UTC - 4:00)**************************
Loading Dump File [C:\Users\Owner\SysnativeBSODApps\043013-8002-01.dmp]
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Built by: [B]7601[/B].18113.amd64fre.win7sp1_gdr.130318-1533
System Uptime:[B]0 days 15:24:40.200[/B]
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys
Probably caused by :[B]dxgmms1.sys ( dxgmms1!VIDMM_PROCESS_HEAP::Free+a2 )[/B]
BugCheck [B]1A, {403, fffff68000033f00, cab000009db2386f, fffff6800002c4f8}[/B]
BugCheck Info: [url=http://www.carrona.org/bsodindx.html#0x0000001A]MEMORY_MANAGEMENT (1a)[/url]
Arguments: 
Arg1: 0000000000000403, The subtype of the bugcheck.
Arg2: fffff68000033f00
Arg3: cab000009db2386f
Arg4: fffff6800002c4f8
BUGCHECK_STR:  0x1a_403
PROCESS_NAME:  chrome.exe
FAILURE_BUCKET_ID: [B]X64_0x1a_403_dxgmms1!VIDMM_PROCESS_HEAP::Free+a2[/B]
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
[/font]
3rd Party Drivers:
The following is for information purposes only.
Any drivers in red should be updated or removed from your system. And should have been discussed in the body of my post.
Code:
[font=lucida console]**************************Tue Apr 30 00:24:29.373 2013 (UTC - 4:00)**************************
[COLOR=RED][B]Epfwndis.sys                Thu Apr  9 08:43:20 2009 (49DDED68)[/B][/COLOR]
[COLOR=RED][B]UCTblHid.sys                Wed Jun 10 04:02:35 2009 (4A2F689B)[/B][/COLOR]
[COLOR=RED][B]PTSimHid.sys                Wed Jun 10 04:03:18 2009 (4A2F68C6)[/B][/COLOR]
[COLOR=RED][B]TClass2k.sys                Wed Jun 10 04:03:44 2009 (4A2F68E0)[/B][/COLOR]
[COLOR=RED][B]PTSimBus.sys                Wed Jun 17 22:20:48 2009 (4A39A480)[/B][/COLOR]
intelppm.sys                Mon Jul 13 19:19:25 2009 (4A5BC0FD)
epfwwfp.sys                 Mon Nov 16 02:46:30 2009 (4B010356)
epfw.sys                    Mon Nov 16 02:46:31 2009 (4B010357)
eamon.sys                   Mon Nov 16 02:51:14 2009 (4B010472)
ehdrv.sys                   Mon Nov 16 02:51:48 2009 (4B010494)
amdxata.sys                 Fri Mar 19 12:18:18 2010 (4BA3A3CA)
[COLOR=RED][B]nusb3hub.sys                Thu Apr 22 21:34:35 2010 (4BD0F92B)[/B][/COLOR]
[COLOR=RED][B]nusb3xhc.sys                Thu Apr 22 21:34:36 2010 (4BD0F92C)[/B][/COLOR]
IntcDAud.sys                Tue Aug 31 09:07:05 2010 (4C7CFE79)
iaStor.sys                  Mon Sep 13 21:23:32 2010 (4C8ECE94)
HECIx64.sys                 Tue Sep 21 12:59:04 2010 (4C98E458)
e1c62x64.sys                Tue Sep 21 17:34:15 2010 (4C9924D7)
igdkmd64.sys                Fri Oct  1 17:14:28 2010 (4CA64F34)
RTKVHD64.sys                Tue Oct  5 05:58:40 2010 (4CAAF6D0)
MpFilter.sys                Wed Oct 31 18:43:06 2012 (5091A97A)
[/font]
http://www.carrona.org/drivers/driver.php?id=Epfwndis.sys
http://www.carrona.org/drivers/driver.php?id=UCTblHid.sys
http://www.carrona.org/drivers/driver.php?id=PTSimHid.sys
http://www.carrona.org/drivers/driver.php?id=TClass2k.sys
http://www.carrona.org/drivers/driver.php?id=PTSimBus.sys
http://www.carrona.org/drivers/driver.php?id=intelppm.sys
http://www.carrona.org/drivers/driver.php?id=epfwwfp.sys
http://www.carrona.org/drivers/driver.php?id=epfw.sys
http://www.carrona.org/drivers/driver.php?id=eamon.sys
http://www.carrona.org/drivers/driver.php?id=ehdrv.sys
http://www.carrona.org/drivers/driver.php?id=amdxata.sys
http://www.carrona.org/drivers/driver.php?id=nusb3hub.sys
http://www.carrona.org/drivers/driver.php?id=nusb3xhc.sys
http://www.carrona.org/drivers/driver.php?id=IntcDAud.sys
http://www.carrona.org/drivers/driver.php?id=iaStor.sys
http://www.carrona.org/drivers/driver.php?id=HECIx64.sys
http://www.carrona.org/drivers/driver.php?id=e1c62x64.sys
http://www.carrona.org/drivers/driver.php?id=igdkmd64.sys
http://www.carrona.org/drivers/driver.php?id=RTKVHD64.sys
http://www.carrona.org/drivers/driver.php?id=MpFilter.sys
 


Last edited:
#3
I ran Prime for 6-7 hours and everything seemed fine. Then i ran Memtest and on Pass 0 test 1 there was an error of 7939.3 mb, and on test 5 several appeared of 8003.3 mb.

Memtest is still running (I am on a laptop) so i'll edit this post (Or reply if gets replies) with more errors showing.

Btw i haven't installed any drivers or windows updates yet. Wanted to do the runs first.

Edit: Pass 1 Test 5 had the 8 error messages of 8003mb. Test 6 had the 7939 one.

Edit: Same 8003 errors on Pass 2. If keeps happening i will just say it once all 7 passes are done so i am not all day editing this just for say that there's a big problem arround that.

Edit: Yeah seems is giving the same Failing Adress at the start of each Pass. 8 Test 5s and one 6. I am at Pass 4 but seems that way.
 


Last edited:
#4
Bumping but also posting pictures of the memtest results. As i said, in all 7 passes it gave several errors on Test 5, and 1-2 on Test 6.

I consulted my boyfriend after he checked the pictures, and told me probably a memory stick is bad. Tomorrow we might try memtest again by removing one of the sticks.
 


Attachments

usasma

Fantastic Member
Microsoft Community Contributor
#5
RED in the bottom half of the MemTest86+ screen is bad.
It is either bad RAM or bad slot(s).
Around Step 6 or 7 (at this link: Memory Diagnostics ) is a procedure for ruling out sticks and slots. Try that to see what you get.

Wait to fix the other problem until after you've solved the RAM/memory problems.
Run MemTest86+ afterwards to be sure that the errors are gone.
 


#6
My family forced me to take it to repair, and seems that they just cleaned out the dust. I am running memtest again just in case Since they probably manipulated the sticks), and so far only brought a single error on Test 3 Pass 0 (In the attached picture memtest is going through Pass 1).

I will leave Memtest running, but if this is the only error i don't know what to do now then.

Edit: After 3 hours i tried to run it again just for curiosity, and now gets the error on Test 2 instead of 3 in the same Address. Also, in both checks during Test 4 the Error count (Not red) increases by 70-80 on each pass.

2013-05-02 21.18.15.jpg 2013-05-03 00.06.48.jpg
 


Last edited:

usasma

Fantastic Member
Microsoft Community Contributor
#7
I liken memory errors to errors in your checkbook.
If the error is in the cents column (0.01), then it's not a big deal
If the error is in the dollars columns (1.00), then it becomes a big deal

Unfortunately, you don't known which "column" the error is in with memory - so to be safe you should replace the stick that's causing the error.

Also, since you paid to have a shop fix this, I'd suggest asking them what to do - as it's (IMO) clearly not fixed. If they replace parts they will have to charge you some more - but the diagnostics shouldn't be charged for (as they did them already).
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top