Weird Internet Issues

Experts, I am having a problem I am just stumped on and need some help. Installed a new Dell Optiplex 390 (realtek NIC) on a customer network and Internet Explorer, Firefox, etc. work fine. However, when malwarebytes tries to update it times out, when I try to install Windows Live Messenger it times out, and additionally, other programs do the same. It seems only browsers work. I have unchecked the proxy setting and honestly tried everything I have read or could find in forums and on the net. At this point the machine is a virgin install of Windows 7 Ultimate (I thought maybe Pro might be the issue or the OEM install) and there is NOTHING on it by all Windows Updates and of Malwarebytes (which is my testing tool to see if the problem is solved). I can take the machine home or put it on any other network and it works like a champ. I have already consulted Cisco about the router and switches and they can find nothing on why this issue is happening. Bottom line, I am stumped. I am seasoned professional and will no doubt feel silly when a solution is offered up I did not think about. However, I need help and fast. Thanks in advance!

Check the firmware (updates) for the router. Run MBSA 2.2
Run in cmd as Admin, sfc scannow

(BUT), Sounds like the issue is not in the computer since, it is fine elsewhere. Try a different router, etc.

Check the ping results


The router is a Cisco 1811 router. One note, all the Windows XP Pro computers on the network work flawlessly. Ping results are consistent with very little drops.

Ok, hooked a standard broadband router up tonight (DLINK) in place of the Cisco and Windows 7 works perfectly with this setup. Looks like I am now going to troubleshoot the problem from the Cisco side. Possibly an ACL issue on the public interface would be my guess. Just wanted to provide an update. Thanks Drew for replying.

You're welcome. The interesting thing is, I've come to prefer D-link over Linksys...glad you have things ok, now.


Thing is, these are actually true Cisco 1811 Routers. I have a TAC open with Cisco. Let's see what happens.

Quick update from my shop: We had similar issues with our first Optiplex 390, could browse the WAN but no internet access. To make matters worse, the issue only happened most of the time. We did standard troubleshooting, release/renew IP, flushdns, change cables, etc... After a week I was ready to send it back to Dell with a nasty note. We were ready to start killing chickens in the graveyard at midnight when I instructed one of the guys to get on the horn with Dell and get it fixed or they'd be getting it shipped back.
During a troubleshooting session with Dell, he was killing processes one at a time and found that Bonjour was the problem. The program came loaded on the machine from Dell and we hadn't seen any issues with it on other machines.
We uninstalled Bonjour and the system is running fine.
I'd like to know if any others have had this same issue.


Fantastic Member
Bonjour has been a trouble maker for years, if you don't need it get rid of it. It has to with Apple software like Itunes, quicktime, etc.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.