Why can't install any program in Windows 7

#1
When I install any program in Windows 7, a dialog box will pop up, saying "Unspecified error"

Please view the attachment
 


Last edited:

reghakr

Essential Member
#2
Hello and welcome to the Windows7forums.

Did you upload the graphic as an attachment, as I see no file.

Is this a new install or has Windows 7 been installed for a while?

Sorry for all the questions, but..............
In order to troubleshoot your problem we need to know more detailed specs of your system hardware.

1. Go to Start > Run, and type msinfo32, look under the Components section for hardware identification
2. Go to Control Panel > Device Manager and look for any entry that has a yellow flag beside it
3. The manufacturer name and model number of your PC, if applicable
4 Please fill out your computers specs in the User Control Panel here on the site as well. It will then appear next to your name. look at my posting and you'll see the drop-down arrow.

The exact make and model of your motherboard would be of great help also.
Are you using the 32-bit or 64-bit version?
Also, go to Start > Run, and type eventvwr. Expand the Windows logs and look under Applications for red or yellow flags.

Post back with an Event ID listed under one of those red flags.
 


#3
Thank you REG HAKR for your quick reply.

I do have upload a graph, please check. It's a bit small.

1. Components check, seems ok
2. Device Manager, I can't open it, still "unspecified error", but all hardwares seem running well
3. acer Aspire 3680
4. will do that

32-bit version Windows 7, Build 7100

I can't run eventvwr, still "unspecified error"

I installed Windows 7 two weeks ago, and it ran well. I don't know what happened today, I only tranferred something by USB disk to the computer.
 


slide

New Member
#4
If you're willing to play around, try booting into safe mode and then disable your sound system. Reboot normal and see if these problems persist. Long shot but if nothing else works, you may as well try it.
 


#5
I have not found any sound control in safe mode.
 


Last edited:

slide

New Member
#6
OK. Can you access DM in safe mode? If so, you are saying there is no sound / multimedia device?
 


reghakr

Essential Member
#7
You have some very serious problems.

Did you just install the RC or gas it been installed for a while?

It letter F: a removeable USB drive?
 


#8
To slide, no sound.

To reghakr, the RC has been installed for a while. I think there is a serous problem in the system, but I don't know why it happened, I almost have not done anything, it happened suddenly.

Now, I can't run almost all the programs, all the reasons are "Unspecified error", for example, I can't access computer management, device management, etc.

Thank you both, slide and reghakr.
 


#9
I have reinstalled my Windows 7

it seems ok now

thank you all
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.