Widen date/time area in taskbar system tray

gogreen

Honorable Member
On my laptop I'd like to widen the day and date area so that the day and date fit on one line. For instance, for today, I'd like it to display "Friday/09/16/2016." I have made this change in settings, and when I hover the mouse over that area, the display is correct. But because the display area isn't wide enough, it otherwise shows only the time. This works fine on my desktop PC--plenty of room there.

I don't want to increase the taskbar height. I want only to widen the dat/time area to accomodate the day and date on one line.

So how do I widen the day and date area on my laptop? Thanks.
 

Neemobeer

Cyber Security Engineer
Staff member
There is no way to make the system time wider that I know of. You can right click on the taskbar, select properties, and uncheck "use small taskbar buttons" and the time/date should take of two lines and be visible.
 

pnamajck

Honorable Member
gogreen … there's a little-known and seldom-used feature … resides in windows control-panel ('region' option/settings).

once you open the region interface … 'format' tab should be in front of you … you may/mayn't adjust some of these settings. at the bottom, click on "additional-setting" … all sorts of formatting is allowed for customization on the 'date' tab.

couple things i would encourage/suggest:
  1. create system-restore point … name it as "adjusted_systemtray_datedisplay" … and make sure the process took successfully.
  2. take screen-shots of each "default" interface-window … and save each with appropriate name (adding "default" to file-name). you might create folder for these screen-shots (naming it "win-10 configs").
  3. take screen-shots of your "acceptable" configuration … utilizing similar routine as above.
  4. take screen-shots of your system-tray/clock before/after revision … utilizing similar routine as above.
  5. within that same folder, you might save text-file (with similar naming convention). within that text-file, you could state any anomalies you found … or web-sites which helped your cause … if you applied the configs locally/globally … whether or not you had to unlock the taskbar before revising config … installed any tweak-utility … etc.
i don't think these specific settings require admin-priv, gogreen … so you should have smooth sailing.

Image1.png Image2.png

oh, gogreen … you might find this of interest:
 

gogreen

Honorable Member
Thank you, Neemobeer. When I right-click the taskbar, I don't see a "properties" option. I get the attached.
 

Attachments

  • right-click.png
    right-click.png
    11.9 KB · Views: 393

gogreen

Honorable Member
Thank you, Pnamajck. I replied to Nemobeer before I saw your message. I have tried the adjustments you suggest, but the area isn't wide enough on my laptop to show the day and date on one line. When I make those changes in the Regions settings and customize format, the date and time changes only to the time.
 

gogreen

Honorable Member
Thanks, guys. To clarify, my laptop is not allowing me to use any Long date or Long time formats--only Short date and Short time. Shouldn't make any difference whether it's a laptop or a desktop PC. So how do I get the laptop to allow Long dates and Long times?
 

gogreen

Honorable Member
I have seen "fixes" that use 3rd party apps, but I prefer not to do that, if I can avoid it. I must be misunderstanding something.In Neemobeer's graphic in post #10, how do I choose the long date? I've tried hovering the mouse over my choice to highlight it, selecting it with left click, and selecting it with right click. No matter what, Windows prevents my choosing a long date.
 

Neemobeer

Cyber Security Engineer
Staff member
You can choose the long date, you can set the short date to match for format of the long date field if you want the same format.
 

BIGBEARJEDI

Fantastic Member
Premium Supporter
It might clear up some things if we knew the EXACT version of W10 you are running as there are now dozens of versions out there since W10 release date of 7.29.2015. Click on the Start button in W10, and use the <windows-logo-key> + <R-key>which brings up the run command box. Type in the command "winver" into and W10 will pop up a box similar to this:
W10 WINVER CMD STUDIO540 9-17-16.JPG

**NOTE: we need both the Version number (ver.1511 here) as well as the OS Build number (B10586.589) show in the picture above here in the Red Box.

Please post this information back to this thread and we can advise you further.:)

Thanks,
<<<BIGBEARJEDI>>>
 

Neemobeer

Cyber Security Engineer
Staff member
He's on the AU build BBJ. In all older builds when you right click on the taskbar you will see Properties at the bottom on AU you will see Settings.
 

bjc

New Member
@ gogreen:

You're looking for exactly for what I wanted and I found it. It's called YTrayClock, and it's free. Not only is it highly customixable, just as you like, but you can assign whatever distance you want on all sides, top, right, bottom and left.
 

vinwintech

New Member
I did solve my problem. I'm using T-Clock, and it's giving me exactly what I want in the notification area.
Hi @gogreen, I am running into this same problem on my Windows 10 (much higher version of OS Build). But the very interesting thing is that I can swear that my short date format of "dddd, M/d/yyyy" WAS displaying in my system tray without needing to make the taskbar two levels wide. And then, all of a sudden, it stopped showing. The most it will show is when short date is "dd, M/d/yyyy" which is not what I want.

Also, what is T-Clock? Is it a third-party app/tool? I was excited that you too were looking for a solution without having to use third party apps. but sounds like T-Clock is third-party??
 
Top