win 7 64 bit

Discussion in 'Windows 7 Hardware' started by ebrock3, May 10, 2011.

  1. ebrock3

    ebrock3 New Member

    Joined:
    May 10, 2011
    Messages:
    4
    Likes Received:
    0
    I am running win 7pro 64 bit and have a Epson cx9400fax all in one printer. When I click on print on any document it seems to take a long time before it starts to print (8-12 min).I have uninstalled the software and driver and re-installed the latest driver which has not helped.when I run the printer troubleshooter in win7 it does not see the usb printer even tho it is listed as the correct printer port can some one help me?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If the trouble shooter cannot see the printer, then that might explain the delay. There is a troubleshooter on the Epson site.

    Have you tried changing the USB connections?

    I would probably uninstall the printer and any drivers you can. See if Epson has a cleaner to use. Reboot the system. Try again and report back with the ports the printer is using. There may be a problem with the printer queue being set up or some bidirectional or other setting.
     
  3. ebrock3

    ebrock3 New Member

    Joined:
    May 10, 2011
    Messages:
    4
    Likes Received:
    0
    I followed your insts. did a search for epson, removed all, re-installed program and now it's working properly. Thanks for your help
     

Share This Page

Loading...