Win 7 7068 on latitude xt - problem

Discussion in 'Windows 7 Installation' started by Hitori, Mar 31, 2009.

  1. Hitori

    Hitori New Member

    Joined:
    Mar 31, 2009
    Messages:
    4
    Likes Received:
    0
    I'm using dell's latitude xt tablet.
    When i upgraded my system from build 7057 to 7068 i noticed that touch screen stopped working.
    I tried reinstalling n-trig drivers and making clean install of build 7068, but nothing helps.
    Problem solves only switching back to old n-trig drivers (those from vista), but they doesn't support windows 7 multitouch.

    Did anyone experienced such problem on his laptop with this new build ?
     
  2. tristan_yeh

    tristan_yeh New Member

    Joined:
    Apr 8, 2009
    Messages:
    2
    Likes Received:
    0
    DELL Latitude XT2 with Win7 7068

    I install Win7 7068 on DELL latitude XT2 and also install the Win7 multi-touch driver from n-trig website.
    The touch function including single touch can't work at all.
    With Win7 7048 build, the multi-touch can work correctly on DELL latitude XT2.
    Is it OS issue or driver issue?:(
     
  3. lcoleman

    lcoleman New Member

    Joined:
    Mar 19, 2009
    Messages:
    40
    Likes Received:
    0
    The native single touch support on 7068 x64 for Latitude XT2 works for me
     
  4. Hitori

    Hitori New Member

    Joined:
    Mar 31, 2009
    Messages:
    4
    Likes Received:
    0
    Yes, native single-touch works (crappy,but still...),but after installing n-trig drivers for multi-touch it doesn't work at all.
    soon a will test it on 7077 build and tell you the result...cross your fingers ^^
     
  5. LOMF

    LOMF New Member

    Joined:
    Apr 14, 2009
    Messages:
    2
    Likes Received:
    0
    Hi,

    I've too got a Latitude XT2 and I experienced the same issue when I updated (clean install thoo) from 7048 to 7077.
    I found something interessting; There is a service called ntrigserv that points to <<TARGET DIR>\anyserv.exe
    - needless to say, it's not pointing anywhere near where it should, so I changed the path to the right directory - and tried to start the service which now successfully started the service - but instantly stopped it again...

    further research showed that anyserv is trying to run a program called ntrigwatch.exe.. well.. actually it tries to execute C:\Program Files\N-trig\N-trig Software Bundle\N-trig Software Bundle\ntrigwatch.exe" (note the trailing quote!)
    - With or without the quote - the file simply does not exists.

    I also checked the signature of the drivers and found that c:\windows\system32\drivers\UMDF\NtrigDigi.dll isn't digitally signed but starting windows in "Disable Driver Signature Enforcement mode" didn't do squat either.

    Conclusion; I don't know if the ntrigserv service is what causing the problem - since I havn't rolled back to 7048 - I have nothing to compare with (I'm hoping that 7106 might fix it - but I'm waiting for a english release first).

    I've tried to contact n-trig three times the last week (only once about this issue though) but they have yet to get back to me...
    ... and that throws me off abit.
    - Sure, they have no responsibillity to provide support as they are just a hw supplier - but they are saying that it's unsupported by Dell - and therefore (in my opinion) they should take some responsibilliy to help out early adopters... I mean, they do get some great beta-testing for free (yeah - I usually get paid to do this).

    ... they should at least return my emails no matter the reason.

    I'll keep you posted if anythinig develops on my end.

    Best regards

    // Ludvig
    IT-consultant
    Stockholm, Sweden

    ps. At least It's good to know that I'm not the only one using win7 and XT(2).. I've been googling this issues and come up very short which made me almost believe that I was the only one using/strugling with this system) ds.
     

Share This Page

Loading...