Win 7 bsod

#1
This is my first post and I would like to say hi to everyone. I love Windows 7 and I have been using it since RC1. It is one of the best operating systems Microsoft has ever made. Unfortunately, a few weeks ago, I started noticing something peculiar. My PC would not shut down. Sometimes it would stay on for 20 minutes with the Shutting down message. I would have to hard reset or use the power button to shut windows down. Upon normal boot, I would have no meessage that the computer failed to shut down. If, however, the computer would shut down on its own, on the next boot, I will get a BlueScreen :mad:.

I have the following system :


MOBO: Gigabyte X58 U3DR SLI MOD
CPU: I7 920@ 3.5 GHz
COOLER: Noctua NH-U12P SE1366 + AS5
RAM : 6GB TRI KIT G-SKILL DDR3 XMP CL7
Video: CrossFireX XFX ATI 4890 XXX 1GB DDR5 GPU: 1 GHz / MEM: 4 GHz
HDD: 1 * 500GB WD Caviar+RAID 0 2 * 1 TB SAMSUNG SPINPOINT
OPTICAL: Sony Optiarc Labelflash
AUDIO : X-FI TITANIUM
PSU: Corsair CMPSU-750TX
CASE: Antec 902
If up until now I thought that the BSOD was showing up only on shutdown/boot several W7 installs proved me otherwise. I managed to get check the crash dump with WinDG and after running !analyse -v and !poll [the address] I still do not have sufficient information to find the culprit. I do believe something broke and that this is a hardware related issue because yesterday I installed W7 from scratch 5 times and 2/5 I got the blue screen and following reboot. Initially I thought it was my Netgear Atheros driver because it kept disabling my Realtek Gigabit LAN for some reason.





I stayed up all night, can barely see the keyboard now, and I ran :

1. Memtest
2. Linx, Prime95
3. Furmark, 3DMark Vantage.


Everything checks out. Nothing out of the ordinary :(.


Any input would be greatly appreciated. I am at work atm, so I cannot attach the dump file. I will do so when I get home.


Regards,

Wishmaker.
 


Last edited:
#2
I would have to suspect hardware problems... have you reset your router?

The reinstall should have worked to fix any software problems. It worked before with the drivers that came with the iso.

Have you taken your system outside and blown it out with a leaf blower? It sounds like the cpu is overheating.... maybe the power supply is overheating or going out. If you are sure it's clean you can sometimes find out if the powersupply is the problem by unplugging the dvd writer, any additional hard drives or devices that pull power but are not necessary to boot and see if the problem goes away. Definitely put the hard drive where it gets plenty air around it. I recommend everyone put a hard drive fan on. they are under $10.. heat is the enemy of hard drives.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#3
Hi wishmaker,
welcome to the forum and thanks for the informative post.

The fault could be down to a number of things either hardware or software related and it's just a case of tracking it down...
How is the bios? Latest version?

Also, when you ran memtest, did you test one stick at a time? If not, then you might have missed an error. If all the sticks are tested together then this can hide errors. Always test only one stick at a time. (20mins per stick is usually enough).

Have you run chkdsk? Run chkdsk and tick the box for repairing sectors.

Can you boot into safe mode?

Lastly, this link has a few more tips.. otherwise post back :)

How to fix “Page fault in non paged areaâ€ÂÂ￾ error
 


#4
Thank you all for the warm welcome and for your replies. I think I found the culprit. As I already mentioned, I spent all night trying to fix it. I ran MEMTEST but on all memory sticks and not one. Today, after I got home from work, I turned the machine on and look what I found :

1. This picture shows my PC, with 3 G-SKILL RAM Sticks populating the tri-channel slots.



2. The following picture shows how much memory my BIOS actually detects :










As one can see, I have 2 GB missing. So, I started the troubleshooting process. I said its the RAM stick. It broke last night in MEMTEST.

1. Used all sticks in that slot, no go.
2. Used all sticks in the 2nd slot, everything works fine.
3. Used all sticks in the 3rd slot, everything works fine.
4. Used all sticks in the 4th slot, everything works fine.

When I use slots 1, 3, 4 I have 4GB RAM, when I use slots 2,3,4 I have 6GB or RAM. Obviously something happened with this memory channel. Because UD3R does not have memory re-mapping in its BIOS, as an option, but it fully supports it, without it I could not use the computer 2 months with 6GB in tri-channel mode, the explanation is that the mobo broke.


What windows 7 reports when I use 1,3,4.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#5
Hi Wishmaker,
sorry to hear your news.. I was looking at one of your pictures and it was showing your bios of 'FB' (the latest bios update on the gigabyte site is ' F8D'). Have you ever flashed the bios yourself?
 


Last edited:
#6
Hey mate,

The BIOS version for Revision 1.0 is F8D. I have UD3R Revision 1.6. Flashing a BIOS is not a problem. I have the necessary tools, moreover, I flash from Caldera DOS to avoid any mishaps. The Gigabyte archive contains a DOS-Based utility. You can even use the Windows based tool and flashing is like eating candy. The days where Flashing was a pain in the kiniggin ae long gone.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#7
Very true...I especially like these 'dual bios boards' as you have a definite insurance policy..

So your bios is the latest,,oh well just thought it was worth a mention... :)
 


#8
I am AMAZED that you found something this techincal and compliated but I still don't see how it could suddenly - after running normal for months cause your system to automatically reboot or take a long time to shut down. It appeared to have 4 good working gb memory.

I've dealt with the problem of having memory sticks in the right slots and in the right order... many times when building systems or upgrading memory... but once the system booted and ran, it would never run solid for a while then just start having problems related to memory stick positions. Something in the bios must have gotten reset/modified/changed to make the problem show up.
 


#9
I rarely build systems because I am not a computer freak. I built this one because my old Prescott, 512 RAM and 256 9700 Pro, was begging for retirement. I set myself a budget because you know, the lady will shout if you spend tons of money on PCs but she has no probs spending tons of money on bags and shoes. Anywho, as soon as you notice that something is wrong you try to find out what and where. The irony now, I am using slots 2,3,4 fully accessible 6GB just reinstalled windows, nobody will RMA my mobo during the weekend, plus i just bought Crysis Maximum edition, I'll ignore my 12 % loss in bandwidth due to the lack of tri-channel. Will RMA the thing Monday so in a week I will probably have a replacement.

Enough off topic, back to our apples. So far, I've rebooted 20 times, shut down 20 times and the computer works. No BSOD, nothing. What I find puzzling that the dmp had scarce info and you need to tear the guts out of your pc to identify the problem. Oh well, still cursing here so don't mind me :D.


Cheers lads for the support and help. I will definitely get back to you with the latest developments. Who knows, if you hear something smashing on the sidewalk, tis me throwing out my computer. My GCs will prolly go next ;).
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#10
lol, thanks wishmaker and please let us know how you get on.. :)
 


#11
I am a persistent young fellow. I would like to present to you, 'la piece de resistance'.


1. Let's confirm one more time that I am using the tri-channel slots and not the dual channel ones. So there you have it, 1, 3, 4



So yeah, everything is fine, I got the right slots. Lets look now at something. This was earlier in the day. Since then, I've taken out the battery 20 times, I've reset the jumper, I flashed the thing back and forth, am using the latest BETA BIOS for my REV 1.6 called FD4.

This was earlier in the day :




This is NOW



...and crikey, still off by 2 GB





So there you have it folks, my motherboard recognises the RAM stick, but it can't add it to the other 4GB in tri-channel mode. Talk about unlucky.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#12
Man...thats a bummer..
 


#13
I have been reading up, doing some homework what mobo should I get to replace this. In what I saw, many x58 mobos are plagued because early revisions flooded the market. Could it be the I7 IMC? Could the IMC be broken and not recognise tri-channel only dual-channel? Was W7 detecting this and I think it is the motherboard?
 


#14
Ok,, I scanned through the thread.....

When you ran the memory diags,,, did you only let it go one pass?

Optimal results will only come after running Memory Diags for 4 to 6 hours plus.
I would also run Windows Memory Diags and hit "t" after the test starts to run extended tests for the 4 to 6 hours plus.
I have found that MemTest (while good) does not always root out bad memory or bad slots. While WMD usually finds them pretty quick or with int hat time frame.

I would suspect that it is a motherboard problem though, from what I have read.

234 config works,,, but 134 does not... if I read correctly.... I would suspect that either a faulty ram slot or Faulty BIOS?
I am of course only guessing here.

EDIT --- Faulty BIOS (either BIOS or the Firmware) causing incorrect readings of RAM in different locations.
 


Last edited:

kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#15
As one can see, I have 2 GB missing. So, I started the troubleshooting process. I said its the RAM stick. It broke last night in MEMTEST.

1. Used all sticks in that slot, no go.
2. Used all sticks in the 2nd slot, everything works fine.
3. Used all sticks in the 3rd slot, everything works fine.
4. Used all sticks in the 4th slot, everything works fine.

When I use slots 1, 3, 4 I have 4GB RAM, when I use slots 2,3,4 I have 6GB or RAM. Obviously something happened with this memory channel. Because UD3R does not have memory re-mapping in its BIOS, as an option, but it fully supports it, without it I could not use the computer 2 months with 6GB in tri-channel mode, the explanation is that the mobo broke.


What windows 7 reports when I use 1,3,4.
Did you miss the above Tepid?
 


#16
The usable RAM could come from many factors....

Even on 64-bit,, it is my understanding that the system still reserves some memory for certain things,, ie. Video Card

But this may not be the case here.

I will look at my Server 2008R2 install and see what it reports.... my Video card does memory sharing with the system.

But I guess this is moot as the OP already suspects a Bad Mobo.
 


Last edited:
#17
Hey lads,


I know it has been quite some time and I am sorry about that. I was very busy, also waited 3 weeks for my mobo replacement and I've been enjoying 6GB ever since. Unfortunately, my issues are not gone. It seems that for some reason windows 7 hates me . My computer refuses to shutdown sometimes and I have to shut it down on my own. The eternal issue, I turn on my pc and W7 does not know that it did not shutdown properly. Moreover, I also got a bluescreen a few days ago. I analysed the dump and I saw it is a driver issue. I did not really pay attention to it, I was gonna format anyways. Today, I wanted to identify the culprit and I decided to run verifier. I did and BSOD, BSOD, BSOD :(.

Special Pool detected, memory corruption
I had to use last known config and to reset the verifier to boot normally. So, now I am running memtest on every 2GB stick, individually. I emptied all my channels except the first one and testing. Could something have happened to my memory when my 1st tri-channel slot went dead?
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#18
It might well have done.... but your doing the right thing so let's hope you find the bad un and you can just RMA the bad stick (if there is one)..
 


#19
RAM's good according to Memtest+4.0


Loading User Symbols

Loading unloaded module list
....
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck C1, {fffff980161f0fd0, fffff980161f0ff4, eb402c, 24}

*** ERROR: Module load completed but symbols could not be loaded for WN111v2x.sys
Probably caused by : WN111v2x.sys ( WN111v2x+125fd )

Followup: MachineOwner
---------

4: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION (c1)
Special pool has detected memory corruption. Typically the current thread's
stack backtrace will reveal the guilty party.
Arguments:
Arg1: fffff980161f0fd0, address trying to free
Arg2: fffff980161f0ff4, address where bits are corrupted
Arg3: 0000000000eb402c, (reserved)
Arg4: 0000000000000024, caller is freeing an address where bytes after the end of the allocation have been overwritten

Debugging Details:
------------------


BUGCHECK_STR: 0xC1_24

SPECIAL_POOL_CORRUPTION_TYPE: 24

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

PROCESS_NAME: System

CURRENT_IRQL: 0

LOCK_ADDRESS: fffff8000348e400 -- (!locks fffff8000348e400)

Resource @ nt!PiEngineLock (0xfffff8000348e400) Exclusively owned
Contention Count = 4
NumberOfExclusiveWaiters = 1
Threads: fffffa8004f34b60-01<*>
Threads Waiting On Exclusive Access:
fffffa8004f34040

1 total locks, 1 locks currently held

PNP_TRIAGE:
Lock address : 0xfffff8000348e400
Thread Count : 1
Thread address: 0xfffffa8004f34b60
Thread wait : 0x4ea

LAST_CONTROL_TRANSFER: from fffff800033917c3 to fffff8000328bf00

STACK_TEXT:
fffff880`0337dce8 fffff800`033917c3 : 00000000`000000c1 fffff980`161f0fd0 fffff980`161f0ff4 00000000`00eb402c : nt!KeBugCheckEx
fffff880`0337dcf0 fffff800`033bd356 : fffff800`0321a000 00000000`6e70444e 00000000`0000002c fffff880`016b0110 : nt!MmFreeSpecialPool+0x383
fffff880`0337de20 fffff880`016efaa1 : fffff980`160d0fd0 fffffa80`07bd4840 fffff980`161ecf70 00000000`00000006 : nt!ExFreePool+0x9f3
fffff880`0337ded0 fffff880`026555fd : 00000000`00000014 00000000`00000014 fffff880`026c6918 fffff980`00000009 : ndis!NdisCloseConfiguration+0x51
fffff880`0337df00 fffff880`02650072 : fffffa80`08f9e1a0 fffff880`0337e138 fffffa80`08f9e050 fffffa80`07cfa060 : WN111v2x+0x125fd
fffff880`0337df80 fffff880`016f10a5 : fffffa80`08f9e1a0 00000000`00000000 fffff880`0337e2d0 fffff980`161ecf70 : WN111v2x+0xd072
fffff880`0337e210 fffff880`016f0793 : fffffa80`07bcdc60 fffffa80`07bd4840 00000000`00000000 01ca66f0`b279537e : ndis!ndisMInitializeAdapter+0x695
fffff880`0337e5d0 fffff880`016f286c : fffffa80`07bcdc60 fffffa80`08f9e050 00000000`00000000 fffffa80`07b97a40 : ndis!ndisInitializeAdapter+0x113
fffff880`0337e630 fffff880`016f0466 : fffffa80`08f9e1a0 fffffa80`07bcdc60 00000000`00000000 00000000`00000000 : ndis!ndisPnPStartDevice+0xac
fffff880`0337e690 fffff800`03731c16 : fffffa80`07bcdc60 fffffa80`07bcdc60 fffffa80`08f9e050 fffff880`0337e820 : ndis!ndisPnPDispatch+0x246
fffff880`0337e730 fffff800`03649bde : fffffa80`07bcdc60 fffffa80`07bd5f90 fffffa80`08f9e050 fffffa80`06849200 : nt!IovCallDriver+0x566
fffff880`0337e790 fffff800`033840ed : fffffa80`07cfa060 fffffa80`07bd5f90 fffff800`03389cd0 00000000`00000000 : nt!PnpAsynchronousCall+0xce
fffff880`0337e7d0 fffff800`03654926 : fffff800`0348e1c0 fffffa80`07bd1d90 fffffa80`07bd5f90 fffffa80`07bd1f38 : nt!PnpStartDevice+0x11d
fffff880`0337e890 fffff800`03654bc4 : fffffa80`07bd1d90 fffffa80`077e001b fffffa80`077e6b00 00000000`00000001 : nt!PnpStartDeviceNode+0x156
fffff880`0337e920 fffff800`03677ea6 : fffffa80`07bd1d90 fffffa80`077e6b00 00000000`00000002 00000000`00000000 : nt!PipProcessStartPhase1+0x74
fffff880`0337e950 fffff800`03678438 : fffff800`0348bd80 00000000`00000000 00000000`00000010 fffff800`036783a0 : nt!PipProcessDevNodeTree+0x296
fffff880`0337ebc0 fffff800`0338c347 : 00000001`00000003 00000000`00000000 00000000`00000001 00000000`00000000 : nt!PiProcessReenumeration+0x98
fffff880`0337ec10 fffff800`03299161 : fffff800`0338c020 fffff800`034f6f01 fffff800`0342f500 00000000`00000000 : nt!PnpDeviceActionWorker+0x327
fffff880`0337ecb0 fffff800`0352f166 : 00000000`00000000 fffffa80`04f34b60 00000000`00000080 fffffa80`04f08040 : nt!ExpWorkerThread+0x111
fffff880`0337ed40 fffff800`0326a486 : fffff880`0316a180 fffffa80`04f34b60 fffff880`031750c0 00000000`00000000 : nt!PspSystemThreadStartup+0x5a
fffff880`0337ed80 00000000`00000000 : fffff880`0337f000 fffff880`03379000 fffff880`0337d0d0 00000000`00000000 : nt!KxStartSystemThread+0x16


STACK_COMMAND: kb

FOLLOWUP_IP:
WN111v2x+125fd
fffff880`026555fd 4883c468 add rsp,68h

SYMBOL_STACK_INDEX: 4

SYMBOL_NAME: WN111v2x+125fd

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: WN111v2x

IMAGE_NAME: WN111v2x.sys


DEBUG_FLR_IMAGE_TIMESTAMP: 48db4b84

FAILURE_BUCKET_ID: X64_0xC1_24_VRF_WN111v2x+125fd

BUCKET_ID: X64_0xC1_24_VRF_WN111v2x+125fd

Followup: MachineOwner
---------
That relates to my netgear draft n stick :eek::eek:!!! Funny thing is that I have another system with the same stick and there are no BSODs :(.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#20
Do you mean you've tried the stick in a different system and it was ok? If so, what os was it running?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.