Win 7 loses Drive Mapping after sleeping

Discussion in 'Windows 7 Networking' started by RickB, Dec 21, 2009.

  1. RickB

    RickB New Member

    Joined:
    Dec 21, 2009
    Messages:
    4
    Likes Received:
    0
    I finally got my NAS mapped to my Win7 machine and when the PC goes into Power Saver (Sleep Mode) it loses the drive mapping. Logging off and back on does not seem to restore the mapping, only restarting.

    Also Win 7 doesn't see the other WinXP machines on the network? I have gone through the normal network settings (seen in this forum) and no luck.

    I did see this recommendation from Trouble but could not find this in Win 7 Home Premium. Win7 did not recognize secpol.msc I tried searching MSConfig but didn't find any policies there.
    Try this on the Win7 machine
    Click start->click run->type secpol.msc
    Go to: Local Policies > Security Options
    Find "Network Security: LAN Manager authentication level"
    Set it like this "Send LM & NTLM - use NTLMv2 session security if negotiated"
    See attachment
    Hope this helps
    Regards
    Randy


    Any help would else the frustration....

    //Rick
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sorry Rick:
    I'm finding out that a lot of things are missing in some of the down versions of Win7 and I sometimes mistakenly write with Win7 Pro and Win7 Ultimate in mind. You need to first consider that networking is really all about high availability of network resources so you may find that sleep and hibernate and various power saving things can impact networking and you may have to decide, to what extent you want to be "green" versus have a functioning network. Having said that, there are several places where you can specifically control the power saving options for your network device. Look in device manager, find you network adapter, right click, choose properties and see if there is a power management tab if so uncheck allow blah turn off blah. Also drill down through your power option setting in control panel, change setting, change advanced power setting, see if there is anything in there regarding your adapter, I know mine has some setting for my wireless adapter.

    EDIT: By the way, the post that you refer to is mainly to address an issue with accessing a device on the network that doesn't support NTLMv2. There is another way to do the same thing within the Windows Registry but that doesn't sound as if it's your actual problem issue.
     
    #2 Trouble, Dec 21, 2009
    Last edited: Dec 21, 2009
  3. RickB

    RickB New Member

    Joined:
    Dec 21, 2009
    Messages:
    4
    Likes Received:
    0
    Hi,

    Changed the power setting for the net adapter but didn't fix it. I looked at the power saver settings and tried to see if any referred to network items like PCI-E and didn't see anything that would have an impact. Never had this problem in XP but can't ferret out where the difference at. Can we set S1, S2 or S3 in Win7?

    Thanks

    //Rick
     

Share This Page

Loading...