By registering with us, you'll be able to discuss, share and private message with other members of our community.

SignUp Now!

Windows 7 Win 7 Second Display not using full display - squished


New Member
May 10, 2009

I am having trouble with the Win 7 RC1 release. I have an ATI x1300 videocard, and connect 2 LG LCD monitors. One is via digital DVI (main screen(, and the other is analog VGA connection. IN this case, the main screen (digital) displays 1680x1050 no problem, while the 2nd says it is displaying 1680x1050, but the screen is "squished" (everything is very narrow).

It only takes up about the 4:3 ratio portion of the screen, with about 2.5" of wasted space on the left, and .5" on the right.

I have updated both monitor drivers from LG (1st W2052TQ and 2nd L204WT).
I have tried updating the ATI CCC/driver for Win7 64, but it is not for the x1300?, so I went with the Vista 64, but it gets an error near the end (useless error about some file not read or something bizarre). Anyway, CCC will not open (appears installed, when I open CCC advanced, wizard, or just CCC - I get the hourglass (spinning circle) for a few moments, the CPU goes up near 80% during that time, but then nothing happens.

I have tried the physical menu on the display, but this doesn't work either.

This 2nd monitor was used as a single monitor with Win 7 betas, Vista, WinXP and never had this problem before.

Any ideas out there?

I'm also getting this problem with my second display device (a wide-screen TV in my case). It's seems that Windows 7 won't strech the display on the second display device to fill the screen, or that somethings wrong with ATI-Windows 7 compatability. (Using ATI myself)
The compatibility with older ATI cards (in this case, X-series and older) pretty much went out the door with RC. You still have a couple months before the Beta ceases to function properly so if you really want to use your current video card, you'll probably want to revert back. Otherwise, you'll have to get an HD card or a Geforce (any cheap one will suffice). I've had to ditch my X1650 Pro for my brother's Geforce 8400 GS to get my widescreen resolution.
Last edited:
right click desktop and go to personalize and let windows do the configuring for you. CCC is useless at this time with your video card. It is no longer supported by ati drivers as of a month or so ago.
Problem solved - kind of

First - to the person saying use personalize - if you read my first post, you can tell I delved much much deeper into trying to resolve this than just using the Personalize feature. The easy way wasn't working and I had to get deep into disabling, deinstalling, swapping digital/analogue, trying ATI's CCC, etc etc.

Lastly - I did finally come up with a work around - that appers to be a bit of a combo of the older LCD just not liking Analogue, and Win 7. Here is the post I posted on Technet:


Just to let you all know.

I have got it working, but not how I would have liked.

I changed the LCDs around, now using the older L204wt as the main (1st) monitor through the DVI/Digital connection, and the newer W2052TQ as the secondary (2nd) monitor through the VGA/Analogue connection,both through the ATI x1300 as mentioned previous.

And now both monitors are showing the true Widescreen 1680x1050, without the secondary being "squished". Strange how the slightly older (9-12 months) L204WT just couldn't handle the real widescreen when it was analogue. I did run this monitor originally in Vista through Analogue and never had any problems until I bought the DVI cable, and was digital for the last year. My other computer has twin DVI connections to an nvidia, but that is still Vista and I never had any problems.

Anyway, this is solved through the workaround, but I really did want to have the newer monitor as the main one - oh well, guess that's why it's a trial - to get the bugs worked out :) and we are the guinea pigs.

Dan B.
hey, i signed up just to post a reply.

try changing the refresh rate on the monitor.

i have a toshiba hdtv and the picture was squished, however changing it from 85Hz to 60Hz refresh rate solved the problem instantly.
Resolution it`s at is 1360x768.
REsponse to Roger, Further Update

Two comments.

Roger - I had tried setting my hz. funny thing was it kept resetting to 59mhz, and I kept setting it to 60, 75, 80 etc and no matter what I did, the screen stayed squished (until I did my final solution and put the older LCD on digital and made it the primary, and put the newer LCD on the analogue/vga port).

Anyway, the megahertz change didn't help, and stranger kept reverting back to 59mhz for some reason.


I ended up upgrading the video card from the x1300 to a HD4650 1gb. I pre-bought Win7 so will be sticking with it, so figured I'd get a more compatible card (actually, nephew blew his up and I used this as an excuse to buy a new one so I could hand my old card down to him). This new card as two DVI outputs, so both displays are full digital, and either can be set to primary without the older version getting "squished". Guess the post about x-series ATI cards just not being supported is pretty accurate. Too bad, that card was only about a year old - ATI used to support their cards a lot longer than that.

(My nephew is like my son - xp works fine for them and they really don't care about using an ancient O/S - so the x1300 will last him a while).

See ya
hey, i signed up just to post a reply.

try changing the refresh rate on the monitor.

i have a toshiba hdtv and the picture was squished, however changing it from 85Hz to 60Hz refresh rate solved the problem instantly.
Resolution it`s at is 1360x768.

Which model Toshiba LCD have you got? Can you play any Directx game with 1360X768 resolution as fullscreen on your TV?

If yes, what is your Nvidia settings?
Toshiba 26HL57.

Yes, I can play full screen games -if- the game supports that resolution. Otherwise the image is stretched or it only take up part of the screen, for example, 1024x768 etc.

I dont use it to play video games though, I use the xbox360 for that.

Oh, and, it's an ATI card, not Nvidia.
Last edited: