Win 7 Spontaneously changing from Dynamic DNS Servers to Static.

Discussion in 'Windows 7 Networking' started by w0wbagger, Oct 13, 2009.

  1. w0wbagger

    w0wbagger New Member

    Joined:
    Oct 13, 2009
    Messages:
    2
    Likes Received:
    0
    Hey all, I have the most bizarre problem, and have tried everything from uninstalling and reinstalling the ipv4 stack using netsh to deleting the static dns servers from the registry, to no avail.

    My problem: My network interface dns server settings are being replaced about every 10 minutes with static ones.

    I set it for "get dns servers from dhcp", and it works fine. After about 10 minutes, however, it changes to "static", and 2 dns servers are in there. Weird thing is, I reinstalled windows from scratch, and they *still* show up.

    Switching manually using the GUI or using netsh back to "get dynamically from DHCP" works for about 10 minutes, after which it's right back to static.

    has anyone seen this before, or have any idea why it might be happening? It's killing me.

    Thanks,
    W0wbagger
     
  2. nomticus

    nomticus New Member

    Joined:
    Nov 2, 2009
    Messages:
    2
    Likes Received:
    0
    Any luck?

    I am now running into this same issue. Have you figured out what is causing this? In my situation, the DNS servers are valid, but my firewall policy is preventing the user from proper resolution. I'm not inclined to think that it is malware because it using valid DNS server IP addresses.
     

Share This Page

Loading...