Win 7 won't let me run chkdsk from command prompt

#1
I ran one of the performance reports today, which claims I have a disk with the dirty bit set. Recommended running chkdsk..... Fired up a command prompt and typed

chkdsk v: /f/r/x

And got:
Access Denied as you do not have sufficient privileges.
You have to invoke this utility running in elevated mode.

SO, I right-clicked and ran the command prompt as an Administrator. EVEN THOUGH I'M ALREADY AN ADMINISTRATOR.

Got exactly the same result.

Went into the command properties and SET the thing to "Run as Administrator".

Same result.

UAC is turned OFF.

There are days with Windows 7 where I feel like everything is 2 steps forward and 1 step back. How do I make it let me do a simple chkdsk - no I DON'T want to set something to have it run at boot, or go find some 3rd party program to do the same thing. I just want to run chkdsk from this box from a command windows.

How do I do this?
 


#2
Works here??
 


#3
That's great. It means it does work... So HOW do I make it "work HERE"?
 


#4
I assume cmd works or you can't get to the command prompt...
Do other programs like bcdedit, defrag, ftp, msconfig, where, etc. run from the command prompt?
 


#5
I can get a command window with no problem. Defrag, msconfig, ftp all work fine from command prompt. Only thing that complains is chkdsk... Is there a service I might have turned off or a program feature I might have disabled that'd cause this not to work?
 


Mitchell_A

Excellent Member
#6
you can run chkdsk.exe directly from your Windows directory.. Might have to add some start parameters though.
 


#7
Driver Issue

Hi dkperez,

It looks like a driver issue. kindly update your disk drivers and mobo chipset drivers.

Once you have done that restart the computer.

You should be good to go.

Check the following link for more info:
I am unable to run chkdsk in Win 7 32 bit Pro. Details are below but I would also like to run the Intel RAID Management Software specific to this configuration. That software seems blocked somehow by Win 7 but ran properly in XP. Any suggestions?
 


#8
Re: Driver Issue

The problem is with the hard disk and not windows 7. check that you can access the hard disk before invoking check disk in elevated mode.. ;)
 


#9
Temporarily switch off your antivirus software that protects your file system. For example, Avast can cause such privilege problems.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.