Win 7 x64 won't recognize my wifi card

Discussion in 'Windows 7 Hardware' started by Dmasterfunk, Jun 9, 2009.

  1. Dmasterfunk

    Dmasterfunk New Member

    Joined:
    Jun 9, 2009
    Messages:
    2
    Likes Received:
    0
    Hey all,
    Recently installed the Win 7 x64 RC and it does not recognize my wifi card (Abit Airpace Wi-Fi Wireless Network Adapter), as in it does not show up in the device manager. It does work in vista x32, and also worked in vista x64 when I had it. I've installed the motherboard drivers to see if that would effect anything, but not change. I tried installing the software that comes with the wifi card, and it does not find the card either (no updated drivers are available on the manufacturers website either).
    I've searched other forums, and it seems others may have had similar problems, but they were able to get windows to recognize their card after shutting down, switching off the PSU, waiting a few minutes and rebooting. This has not worked for me.
    Another note, in an earlier beta of win 7 x64, the card was recognized and the drivers installed, but it would blue screen each time it connected to the internet or I tried to open a browser.

    Anyone else experiencing similar problems? Any advice? I've tried everything I can think, but I'm out of ideas, besides trying a different wifi card. Thanks for any help,

    -D-

    I'm using:
    Intel Q6600 @ 3.24 GHz
    EVGA 780i mobo
    4x1 Gb @ 1000 MHz
    EVGA 9800 GTX
    Abit Airpace Wifi card
     
  2. loathe

    loathe New Member

    Joined:
    Jan 16, 2009
    Messages:
    1,718
    Likes Received:
    66
    I have seen this before. "this card is actually an atheros chipset card, simply uninstall any abit driver and install the driver for the card manually using Windows 7 default drivers under 'Network Adapters', pick either Atheros AR5006X or AR5006XS."

    Or you can try this driver I found
     
  3. subtilr

    subtilr New Member

    Joined:
    Dec 2, 2009
    Messages:
    8
    Likes Received:
    0
    I have the same exact problem as you, I've read other threads about fixing this problem but I've come to no succession. I just got windows 7 pro x64 and I can't even use the desktop cause I have no internet connection. I've tried removing the abit card, re-installing it, removing the power cord, restarting the computer, none of it has worked, it says that there is no abit wi-fi wireless adapter found, in device manager, nothing shows up either. What I've noticed is that when I remove the power from the computer for about 5mins, then restart the computer, the green LED on the wi-fi card lights up for about 2-3 seconds, after that it stays off. I'm frustrated because I've tried everything, I can't manually install the AR5006 driver because there is no abit network adapter to install them too. I don't want to buy another wi-fi card. Any suggestions on how to get the card to be recognized?:confused:
     
  4. subtilr

    subtilr New Member

    Joined:
    Dec 2, 2009
    Messages:
    8
    Likes Received:
    0
    Not sure if this has to do with anything but the model name for the abit card is AW-GE870
     
  5. subtilr

    subtilr New Member

    Joined:
    Dec 2, 2009
    Messages:
    8
    Likes Received:
    0
    Hey Drew, I downloaded that, but when installing, it stops because i need to "Insert or re-insert" the wifi card. I've done both and it still doesn't recognize the abit wifi card :[ If its recognized I know I wouldn't be having this problem, but how can I make the card recognized?
     
  6. subtilr

    subtilr New Member

    Joined:
    Dec 2, 2009
    Messages:
    8
    Likes Received:
    0
    Ok. forget it I've tried everything. Im just going to go buy a compatible wifi network adapter.
     
  7. hondekster

    hondekster New Member

    Joined:
    Jan 30, 2010
    Messages:
    2
    Likes Received:
    0
    I had the same problem but it works now

    I had the same problem and the same card, and i was able to install manually but the drivers are ATHEROS AR5007EG

    Hope this help

    dexster
     
  8. vickpcfix

    vickpcfix New Member

    Joined:
    Jul 24, 2011
    Messages:
    2
    Likes Received:
    0
    Sweet i created an account because i wanted to recognize this forum for helping me with my wifi abit card windows 7 64bit driver issue, it worked beautiful! using the atheos 5006x driver from windows 7, so ill be giving props too all that save me alot of money and headache :cool: Cheers!~o)
     
  9. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    Welcome to the forum. I am happy that you found the help you needed.
     

Share This Page

Loading...