Win Explorer has no program association, MSO and other files launch Win Installer on d.click or r.cl

Discussion in 'Windows 7 Help and Support' started by Scotty369, Apr 25, 2012.

  1. Scotty369

    Scotty369 Well-Known Member

    Joined:
    Apr 22, 2012
    Messages:
    26
    Likes Received:
    0
    Hi All
    New to the forums but have been a computer user since 1980, so I do have a lot of background. About 2 weeks ago I made a mistake cleaning up installer files. I'd made this same mistake last year but didn't realize it right away and it caused all my MSO links to stop working unless I launched the root program. That time I re-installed MSO14 and it corrected everything.
    This time I caught the problem almost immediately, as files I r.clicked on launched a Win Installer window, which I had to cancel or wait to resolve, and another popup asked for a disc to a program, and after canceling that the normal popup menu arrived. I only had to do this once with my Opus Directory program (replacement for Explorer). I restored the files I'd cleaner and a registry b/u but some damage remained.
    For whatever reason, MSO would not allow re-install although it was registered in CP. Other programs I wanted to remove would no uninstall. Windows update was having problems with NET Framework 4 update. (Solved that by repairing the file).
    So I have this ongoing problem with Explorer no program association, can't d.click on links to open files in MSO, and Win Installer trying to launch on r.clicks or d.clicks on files.
    I've search the net extensively on these problems and seen many similar complaints about various programs showing the "no program associated" error etc. but I have not seen any rock solid solutions, and I must have tried at least 2 dozen fixes from articles I researched.
    I believe the heart of the problem is in Explorer and I'm trying to figure out if there is a way to repair Explorer. There is a possiblilty Explorer itself is OK, because when doing a re-image this weekend to go back to the 15th and start over, explorer opened when needed by the MS engine behind restore operations.
    The other possibility is with Installer, but I've updated the Installer and various other things to no avail.
    Finally there is MSO and something corrupt there.

    So, anyone got some suggestions on how any of these might be tackled? Do you think they are inter-related or is one problem causing all else?

    Thanks, Scotty369[​IMG]
     
  2. Scotty369

    Scotty369 Well-Known Member

    Joined:
    Apr 22, 2012
    Messages:
    26
    Likes Received:
    0
    Since there are no takers on this complex problem, I'll update the situation. I've deleted several Nuance programs like Omnipage etc. as they were not responding properly, would not repair or de-install via Control panel. They were also indicated since when Win Installer popups launched it kept looking for a Nuance install CD. I used REVO to de-install these programs.

    After this I was getting cleaner response when r.clicking on files but not always. MSO14 has been one of the programs that would not launch via d.clicking on a file, and last night could not open DOC files, but was OK with DOCX files. REVO could not see the MSO installation, and while it showed in CP, it had no size associated, and it failed to de-install. I used the manual method to de-install, and although it took a while, the computer came out clean and rebooted fine.
    How to uninstall or remove Microsoft Office 2010 suites

    Explorer still has issues with "no program associated". Before re-installing anything I need to track that problem down and repair it. Will attempt a repair from boot or win7-64 DVD. Any other thoughts?
     
  3. Scotty369

    Scotty369 Well-Known Member

    Joined:
    Apr 22, 2012
    Messages:
    26
    Likes Received:
    0
    A further update - re-installed MSO and it complained about some Groove files but since I don't need Sharepoint I circumvented it by setting it to install on first use. Ran fine and finally I could access all my DOC and DOCX files, plus double clicking on such files opened MSO Word as it should be.

    However, still have the Explorer problem:
    Explorer Red-X.
    when I try to launch Explorer. Not coming up with any answers fast. I did try disabling all other shell extensions of non-MS programs but that didn't work. How can this be repaired?
     
  4. Scotty369

    Scotty369 Well-Known Member

    Joined:
    Apr 22, 2012
    Messages:
    26
    Likes Received:
    0
    SOLUTION AT LAST - I had stumbled upon a solution but at the time was too brain fogged to recognize it. Explorer itself was working as it launched when activated by another program that needed an Explorer window for accessing or saving files. Also, if anything had been really wrong with Explorer, since it is an integral part of Windows, my icons etc would not display. Folders I had created could open OK, and that was proof that Explorer was working. It was just the taskbar icon that displayed the error, or by going right to Explorer.exe in c:\windows and clicking on it, that the popup "no associated program" occurred.

    For the taskbar icon, when looking at the properties, the target was C:\Windows\explorer.exe. This is equivalent to going directly to the file and clicking on it, ergo the same problem. Based on a solution I found on a forum which I can't locate at the moment, I replaced the target with an environment variable %windir%\explorer.exe and BINGO, the icon now launched Explorer showing the "computer" directory. It still didn't solve clicking directly on Explorer.exe.

    I had some other information form a forum to add a number of entries to the registry but I was not able to follow the method given and the registry balked at trying to load the information in the format given. So next I examined my registry in my Win7-64 PC against my Laptop Win7-32 and noted in HKEY_CLASSES_ROOT\Folder\shell there was only the subkey "open\command". In my Laptop there was open\, opennewprocess\, opennewwindow\, and explore\ all followed by "command". These appeared to correspond to the suggestion from the forum mentioned earlier, so I exported each relevant key from my laptop on a USB and merged them with my registry on my PC, after backing up my registry to be safe. BINGO again, with the new subkeys added Explorer itself launched when clicked on.

    What initially cleaned my registry of these entries I'll never know, but now I have the process carefully documented and saved on my PC troubleshooting documentation. The following registry entries should be present to properly allow Explorer.exe to launch if pointed to:

    [HKEY_CLASSES_ROOT\Folder\shell\opennewprocess\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

    [HKEY_CLASSES_ROOT\Folder\shell\opennewwindow\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

    [HKEY_CLASSES_ROOT\opensearchfilefolderresult\shell\open\command]
    @=""
    "DelegateExecute"="{99969a8f-27e6-4adf-ab9f-b5b5e90d4733}"

    [HKEY_CLASSES_ROOT\Folder\shell\explore\command]
    "DelegateExecute"="{11dbb47c-a525-400b-9e80-a54615a090c0}"

    [HKEY_CLASSES_ROOT\WMP11.AssocFile.m3u\shell\Enqueue\command]
    "DelegateExecute"="{45597c98-80f6-4549-84ff-752cf55e2d29}"

    The above was from a 2009 Neowin forum. The last entry refers to Windows Media Player. I didn't install this entry as I wasn't sure what it had to do with Explorer. My registry does not have the "Enqueue" subkey but Explorer seems to run fine now without the annoying "no program associated" popup. Maybe later I'll figure out if this is really needed on not. seems to be an association between Explorer and WMP.
    So for anyone having related Explorer "no program associated" errors it is your registry entries that are bust, and can easily be fixed by copying all the relevant HKCR\folder\shell\* keys from one Win7 computer to another. It does not appear to matter if it is 32 or 64 bit OS.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Wow, thanks Scotty, for sticking with it and keeping us up to date on your progress. Great to here that you managed to resolve your issue and thanks again for posting that resolution here. I'm certain that it will prove helpful to someone down the road.
    Much appreciated.
    Randy
     
    1 person likes this.

Share This Page

Loading...