Win7 completely unable to assign IP addresses automatically

Hello. I've been having problems for several weeks now with connecting to the Internet. This first started when I took a trip to another country and found that suddenly my netbook could not connect. I looked at a friend's settings and put the same for my netbook's Ipv4 settings.

Now, when I returned, I found that I had the exact same problem over and over - I move around quite a lot, and each place has different settings. So I've been screaming obscenities at my computer a lot. Since I don't know each network's correct settings off the top of my head.

I'm *this* close to throwing things and I hate my computer with a burning, fiery passion now. What the **** is going on? Btw my computer literacy is like... lower-intermediate. So if there's any specific information I should give, point out where I'm supposed to look for it and such. Oh and the netbook is an S12 Lenovo.

Hi. We'll get to the cause of issues one way or another.

Do you have mdnsrepsonder.exe in the task manager?

Regardless if yes or no, open an elevated command prompt. Copy/paste each of these commands one at a time and press enter after each. Then reboot to test:

netsh winsock reset
netsh int ip reset c:\resetlog.txt

Hi. No, there is no mdnsrepsonder.exe in the task manager, just the usual stuff. Since I'm quite anal about checking the task manager (don't ask why, I don't know), I'm fairly sure I haven't noticed suhc a program lately either. I tried entering the commands and rebooting, but alas, it was for naught. I looked at the wireless settings and the bastard appears to know what the correct DNS server is, but the line for autoconfigured Ipv4 was just completely wrong. I've noticed it keeps putting something like 169.254.???etc for the IP address in every wireless network it encounters, while the correct one would be something like

That 169 address means that it isn't pulling a proper address from the router's DHCP server. You should check that the DHCP server is enabled in the router. Also check that the mac address filtering of the router is off - or - that if it is set to on, that the computer's wireless adapter mac address is added to the whitelist.

In Windows' start menu, type services.msc then press enter. Use this screen to make sure the DHCP client service is set to automatic and also currently started and running too.

Also make sure that the WLAN AutoConfig service is set the same and running too.

If you have any software installed for the wireless adapter, uninstall it. Make sure it doesn't uninstall the driver itself though.

Last edited:
The DHCP server is enabled. Mac address filtering is off. The DHCP client service is set to automatic and is running. Anyway, this is a problem I have everywhere I go, not just with this specific and by coincidence my home network - I can't very well check the router settings in places where I don't have access to the router, right? When I move around with my partner and our laptops, he can connect to wireless networks just fine and I'm the one left entering Ipv4 settings manually.

Uninstall all your security type software in safe mode using the tool(s) found here:

AV Uninstallers - Windows 7 Forums


Update your wireless driver from the laptop manufacturer's website.


The first thing above is probably the issue. Especially if Norton/Symantec or ZoneAlarm is installed but definitely can happen with others.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.