Win7, ICS, LAN, Wifi, and some ASPRIN!! :)

Discussion in 'Windows 7 Networking' started by Actaeon, Apr 10, 2010.

  1. Actaeon

    Actaeon New Member

    Joined:
    Apr 10, 2010
    Messages:
    4
    Likes Received:
    0
    Hi All,

    I'll try to keep this as short and sweet as possible without leaving anything out. I would ~greatly~ appreciate some help with the issue.

    For many years now, I have been running the following setup for my remote office and home network

    DSL modem (with ALL Gateway/DHCP/PPPoE Features OFF)

    LinkSys RVS5000 Router - Acting as DHCP, PPPoE, Wireless access point etc. I have assigned the IP Pool to be 192.168.254.1 -> 50. I did this on purpose because my office in orlando that I VPN into is using the 192.168.1.XXX pool, and I didn't want any IP Conflicts while my VPN was up between my remote office and home network.

    My Windows XP workstation, Static assigned to 192.168.254.3 via Linksys 54G PCI card (Running Cat5 was not an option to my desk location). I then have a Linksys 5 port Hub plugged into the LAN port of this workstation, and my voip phone plugged into the hub.I had the LAN TCP/IP set to a static of 192.168.254.X and the default gateway set to the same as the PC (192.168.254.254, which is the Router) I had ICS turned on, and it had no problem sharing the Wireless with the LAN/Hub/voip phone setup. I would also do this with my XP laptop which allowed me to move throughout the house and work, with my phone. Essentially I was sharing the wireless internet out to the LAN and to the phone with a hub instead of a crossover cable.

    Ok, so long story short, I recently had to upgrade the machine from XP to Win7 x86. I've gotten everything installed and arranged, but am having a doozy of a time getting my ICS setup working again. I have assigned the same workgroup, (not homegroup) and turned on the ICS. I then added the LAN setup, just as it was, (using an address from my 192.168.254.XXX local pool for the LAN just like it was) and it doesn't work. I then (through MUCH trial and error) found that if I set the IP address for the LAN to a static 192.168.1.XX(with the same default gateway, DNS etc) it actually works for some reason..however like i said in the beginning, that is my work's pool/scheme, and everytime I connect my vpn, it kills the phone. as soon as I disconnect the VPN, the phone comes right back up.

    I have tried everything I can think of to find out why 192.168.1.XX works and NOTHING else does and I can't seem to get myself to the answer. Is there something in 7's firewall that says only thing on that scheme get through? I have tried enabling everything for public networks (and private) with no luck.

    Any help is GREATLY appreciated, and I hope I've been clear enough. I can post and logs that would help, just let me know where they are! Thanks!!

    Dale Richard
     
  2. Actaeon

    Actaeon New Member

    Joined:
    Apr 10, 2010
    Messages:
    4
    Likes Received:
    0
    I ended up figuring out this issue and in case anyone else runs into it I wanted to come back and post my findings.

    To successfully share a wireless connection to LAN or wired via a hub or crossover cable you must do the following

    setup the wireless connection as normal making it the standard home network connection. Give it a static ip address and DO NOT turn on ICS. then plug in the LAN connection which will be defined as a public network by win7. Set the properties for the LAN connection to obtain ip and dns automatically. Finally in the network and sharing screen on the left you'll see a link to view adapters. Click there and select both the wireless and LAN adapters using shift-click. Right click on either once they are selected and select bridge connections. 7 will then automatically combine the two networks back in the network and sharing screen. It will assign the LAN connection an ip address and wil consider it to be part of the home or work network that was selected for the wireless connection. If you have any trouble acessing the net after this simply right click on the network bridge in the adapter view page and select diagnose. This will ensure that dhcp is enabled for th bridge (Ive had to do this on two of four occasions)

    I hope this helps someone out there someday.

    Thanks to All for reading!

    Act
     

Share This Page

Loading...