Win7 mutes my Line In automatically

Discussion in 'Windows 7 Help and Support' started by homyakchik, Jul 19, 2011.

  1. homyakchik

    homyakchik New Member

    Joined:
    Jul 15, 2011
    Messages:
    10
    Likes Received:
    0
    Howdy, all

    Actually posting this question from within Win7, so I guess I'm giving it more of a chance than I expected to. :)

    Audio controls question. I have a portable XM radio, hooked up to my PC via Line In. When I unmute Line In, I hear my radio beautifully (and it's a great way to work, listening to your favorites). However, Windows, for some reason, auto-mutes the Line In after just a few minutes. It's annoying, because I haven't found any way to put the mixer controls on the desktop so I can just single-click it back on. Not that I want to; is there any reason Windows pulls this silliness? And if so, is there any way to turn it OFF so my Line In will remain ON all the time?

    Five minutes. It mutes it automatically after five minutes. (Just timed it. Grrr.)

    Reloading the drivers, per se, doesn't seem to be an option; they're microsoft drivers in the first place.

    Growing ever more amazed at how many ways people are finding to fix Windows' shortcomings in 7; I thought the community for fixing up XP was impressive! :)

    Thanks!

    Davey
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I'm not sure it is Windows 7 muting the audio, but there might be some possibilities. There is a setting to mute the audio if using a communications device. Something else might be taking over the audio or changing the audio out options.

    I would assume you are using a stereo plug from your radio to the computer? There may be some type of Digital Rights involved, but I have no knowledge but I will check the XM site for references.

    Do you have other audio software that might be involved? My system has a line in at the front and back of the system. If you have such, have you tried the other input?

    I did find this website that talks about listening to XM from Windows Media Center.
     
  3. homyakchik

    homyakchik New Member

    Joined:
    Jul 15, 2011
    Messages:
    10
    Likes Received:
    0
    Hi, Saltgrass

    I checked the website you suggested; alas, you have to have the part of the XM subscription where you pay extra to listen to it online. I don't (2 physical radios are plenty).

    If it's not Windows auto-muting the sound, then it's gremlins. I can shift back into XP and have zero problem at all with exactly the same setup.

    I've got a Line Out cord going from the radio's home dock to the Line In on the back (a Dell; I've got a headphone jack in front, but not a mike or line-in). I control the input volume with the Line In control on the Audio Mixer (so that the Line In radio sounds the same as, say, Winamp). All of this shows up in Windows 7 Audio Mixer, but Line In is always muted by default, and mutes after 5 minutes (even if I'm in the middle of a song). I'm not sure if it thinks it's saving energy by muting the channel (it can't, after all, tell that there's activity there), but nothing under Energy Settings seems to concern turning off audio functions.

    I don't use Windows Media Center, strictly for Digital Restrictions Management reasons; I use better-working alternatives (Media Player Classic or VLC for video, Winamp for audio)(and a host of excellent tools for video ripping, processing or burning). But as far as the Line In goes, for all Windows knows I could have that hooked up to my kids' radio while they play DJ with the microphone. It shouldn't (I'd think) be trying to 'manage' something that might not need managing.

    Again, the XM radio just keeps plugging; it's Win7 that's turning the channel off, and I can't for the life of me figure why (even if I didn't have anything plugged it, it takes no energy to run).

    Thanks for glancing, though.

    Dj
     
  4. homyakchik

    homyakchik New Member

    Joined:
    Jul 15, 2011
    Messages:
    10
    Likes Received:
    0
    A-a-a-and, replying to myself (as no one else seems to have this problem), I found a solution.

    Basically, my integrated sound (Dell offers no Win7 support for my venerable and much-expanded Optiplex 280) offers Audio Out, Microphone, and Line In. I've got a headset plugged up to the mike input (going to see about making Dragon Naturally Speaking work, or XP's built-in sound-to-text recognition), got my radio plugged into the line in, and of course too many speakers into the audio out.

    Okay. Win7 makes the microphone the default recording device (dunno why, unless there's always some sound coming in to show it's 'live'), says my line in isn't available, and runs off happily. I originally tried setting the Line In as the default recording device, and it wouldn't take. Disabling the phone line (who plugs a phone into their computer any more?) and the microphone (after looking around to see how to re-enable it) allows me to then set my "unavailable" line in as the default sound device. Did so. As of this point I've listening to my radio for about a half-hour; Win7 hasn't helpfully stepped up to mute my device yet. Hopefully this continues past a reboot.

    So far the best thing I've found about Win7 is the fact that Freecell, when stretched, enlarges the cards. Past that, it's not much of an improvement on XP. Still, I promised it a fair trial, and a fair trial it shall get.

    Dj
     

Share This Page

Loading...