WIN7 sound is HORRIBLE

Discussion in 'Windows 7 Help and Support' started by JamesJR, Aug 23, 2010.

  1. JamesJR

    JamesJR New Member

    Joined:
    Aug 23, 2010
    Messages:
    14
    Likes Received:
    0
    I'm running win7 pro 64bit. The sound is crackly, screaching, or just doesnt work at all. Also, my mic doesnt work at all or sends the crackling and screaching to the recieving party.

    Ram:4gb
    Processor: intel core 2 cpu 6300
    Soundcard: Creative X-Fi XtremeGamer Fatal1ty Pro Series Soundblaster

    I have tried uninstalling, reinstalling, restarting, disabling, new drivers, old drivers, fixers, etc. Nothing I have tried is working.

    I'm running split partition xp/win7 pro. On XP OS my sound is perfect, I have used the same exact settings on both OS's with no luck, i have tried tweaking it, I've tried randomness. I'm in need of assistance, please help.
     
  2. fugno

    fugno New Member

    Joined:
    Sep 18, 2009
    Messages:
    399
    Likes Received:
    14
    I almost have the same audio as you but mine is a bit lower end and the HD audio is just out standing on my setup. Where do you get your drivers?
     
  3. JamesJR

    JamesJR New Member

    Joined:
    Aug 23, 2010
    Messages:
    14
    Likes Received:
    0
    the creative site
     
  4. fugno

    fugno New Member

    Joined:
    Sep 18, 2009
    Messages:
    399
    Likes Received:
    14
    I know this is may be a stupid question but did you configure your output devices?(right click on the speaker icon on your tool bar)
     
  5. JamesJR

    JamesJR New Member

    Joined:
    Aug 23, 2010
    Messages:
    14
    Likes Received:
    0
    yeah I've tried all that.

    Another thing that happens that is very annoying is, I'll select all my settings for the soundcard, crystalizer/cmss/3d etc, and everytime I restart or shut down my comp I have to redo all my settings. Where as on my XP OS my settings are permanent. Anybody know how to fix that issue?
     

Share This Page

Loading...