Win7 / XP home network problems: wrong router / firewall issues

I have a WIn7 laptop and an XP desktop connected to a Linksys wireless router (WRTG542); the laptop has two network connections: a wireless connection (when I move it away) and the lan cable. The desktop only has a lan cable connection. But there are problems:

While both computers can see eachother and access shared resources (folders, files, printers connected to the XP), this is the case ONLY when the XP's Windows firewall is turned off.

The Win7 cannot generate a network map for either of the network connections. When I try to create a new network connection, the laptop "thinks" the router is a WRT160N, which I used to have a long time ago (I think). When I try to genreate a map for the wireless connection, I'm told it is public and I don't see where I can change that. BUT for the lan connection, the map correctly identifes the router brand.


Noob Whisperer
First, let's see if we can resolved the sharing issues on the XP machine as it pertains to the Windows Firewall. Right click "My Network Places" choose properties, right click you local area connection and choose properties, go to the advance tab at the top, now click the button that says "settings" now on the exceptions tab, scroll if you need to and put a check in the box that says "File and Printer Sharing" now highlight it and choose the button near the bottom that says "edit" make sure all four protocol/ports are checked in the name column and that the scope column says subnet. OK your way back out of there and see if that makes a difference. This is all assuming you are running Service Pack 3 on the XP machine, if not I would suggest you catch up on all your updates. Let us know if that resolved the sharing issues and we'll go from there.

You don't sound discourteous at all! I am running SP3; File and Printer Sharing was already selected for the Windows Firewall.


Noob Whisperer
Scroll down a little further and see if you see something called "UPnP Framework" and make sure it's checked also. Maybe I should have asked, with the windows firewall turned on, what exactly happens, what exactly is different also check the following
Check and make sure these Services are Started on all Computers
DHCP Client
DNS Client
TCP/IP Netbios helper
Computer Browser
Make sure Network Discovery is turned on, on the Win 7 machines
Make sure file and printer sharing is enable on both and that local firewalls are supporting it. Temporarily uninstall any third party firewalls or Internet Security Suites that may include some type of Firewall applet.
Make sure NetBios over TCP/IP is enabled in the properties of IPv4 on you network.
Look for Bonjour service and temporarily set it to manual or disable and stop, same with mdnsresponder. Also check services near the top for a peculiar string containing numbers and or special characters, disable and stop

All those services are running. I don't have anything named Bonjour. When I turn on the Windows Firewall on the XP machine, it makes the shared resources invisible to the Win7 laptop.


Noob Whisperer
Also to address your wireless network showing as public, try opening the Network and Sharing Center and see attachment

However, on Win7, there are some outbound rules which are diabled. For instance under File and Printer Sharing:
NB-Datagram-Out (Domain)
Echo Request (ICMPv4-Out)
Echo Request (ICMPv6-Out)

and many more are disabled

there are also many inbound rules set to disabled.

Win7 seems far more granular than XP. I have no idea what these do. There are a lot of them.

I can open it. Oddly, I cannot do print screen on the laptop.


Noob Whisperer
I can open it. Oddly, I cannot do print screen on the laptop.
Try using the new windows snipping tool under accessories, snip it save it and upload it here, by selecting "Go Advanced" when you reply and using the paper clip looking thing at attach a file from your computer.
As for the firewall rules in Windows 7, you need to understand that you can apply rules to "Domain" "Public" and "Private" networks so unless you are on a domain or are frequently in coffee shops or some such environment where you would want the network designated "Public" you can pretty much ignore information regarding those rules or simply set them to "No" by uncheck the enable box. What you need to concern yourself with mainly is any inbound rules, impacting "Private" and for the most part everything in the area regarding file and printer sharing should be set to yes by checking the enable box and leaving the allow the connection radio button selected. Again just on the "Private Profile"

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.