Win7upgrade/WRT54G/Now no Internet....

Discussion in 'Windows 7 Networking' started by NOROCKETDOC, Dec 23, 2011.

  1. NOROCKETDOC

    NOROCKETDOC New Member

    Joined:
    Dec 23, 2011
    Messages:
    8
    Likes Received:
    0
    I'm new to this forum but not new to PCs and haven't been able to find my "exact" issue listed in this forum. VERY close but not the same, so I'm assuming people are in my predicament also. I'm sure it will sound familiar to some of you. In fact, I was actually expecting a "sticky" on it when I visited this forum.

    I have one PC (everyone should have at least one). It's a few year old Tosh. Satellite with and Atheros adapter. Ran Vista for a while... no problems. Upgraded to Win7 about a year ago... no problem. Did a recent (last week) upgrade and now it connects very well to my Linksys network, as always, but with no through internet connection. I plugged the same laptop directly into the back of the router and same thing. Clearly a Win7 Update got me. I'm assuming there is a compatibility issue between the very old WRT54g and my recent upgrade. BTW, Router firmware looks up to date.

    I've fiddled with new drivers and rebooting and power resets etc. All the things I've seen listed for "similar" problems. I haven't seen a simple solution to this problem although it seems there should be or have been one from Microsoft.

    Here's where I think it gets weird. I'm thinking of just getting a new router anyway but the kicker is I've got 8 or 9 other devices hitched up that all work fine. Most are Apple products including iPods, an iPad, two laptops and a very old iMac but we've also got a couple game devices too. I guess I'm just surprised there isn't a simple solution and perhaps venting a bit. Must say I've become disappointed with MS over the whole thing but really have enjoyed Win7 and my inexpensive Satellite up to this point. It was a heavily used computer until now. Surprised there isn't much more outrage over the whole thing.

    If anyone has had this problem and has any additional thoughts or recommendations I'd love to hear them. I may try some reformatting and re-installation. Maybe play a bit more with my antivirus software too. Really only use it for internet work so I can't really break it any more :)

    Anyway,
    Thanks for the forum and the possibility of figuring this thing out....
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    It's easy to suspect Windows 7 and a possible upgrade causing the issue and of course it could be, but assuming everything you have said is true and you've worked on possible driver solutions from the respective adapter manufacturer with no positive results (usually a driver update needs to be rolled back as a result of the windows update utility), and with the present proliferation of apple (small A) products on your network I would be more prone to suspect mDNSresponder.exe
    Have a look at this recent knowledgebase article
    The Default Gateway may have been set to 0.0.0.0 on a Windows Vista-based or later OS running Apple
    if the route delete 0.0.0.0 works for you then I would suggest opening the services console and disabling the Bonjour service.
    Regards
    Randy
     
  3. NOROCKETDOC

    NOROCKETDOC New Member

    Joined:
    Dec 23, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks for the quick reply Randy.

    That link you referenced looks promising so I'll give it a go this evening. I had no trouble finding drivers for my Atheros and I also did try to roll back the driver but no go. Your reply has also made me think of a few more things to try if that doesn't work. Just don't want to trash my whole network since I'd be pretty unpopular with the rest of the family if I crash it for all my devices. Sounds like something to try late at night. I'll try a few things and let you know if I figure it out.

    Amazing how you got that hat to stay on the fish :)
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Disabling or setting the Bonjour service to manual and stopping it (on the local machine), should not have any impact on your other network nodes which may happily continue to use Bonjour as most apple devices are wont to do.
    Also using the route delete command on the local machine with likewise have no general network impact.
    Also if you have any other software products that may contain Bonjour/mDNSresponder several Adobe products load the same service in the services console you may see something like this near the top of the lists of services ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762##
    Same deal, double click it, click the stop button and change the startup type to manual or disabled.

    Super Glue.
     
  5. NOROCKETDOC

    NOROCKETDOC New Member

    Joined:
    Dec 23, 2011
    Messages:
    8
    Likes Received:
    0
    Well some good news. I tried the bonjour approach but no luck. Did find one firmware upgrade for my router but that didn't help either. Forgot to mention that I couldn't even bypass the router and hitch direct to the modem. Still limited access. Anyway, I finally just did a complete Re-install of Win 7 and disallowed auto install of updates. Everything is working again... for now. I'll pick and choose the updates to install from now on. There is one Atheros update in the "to do" list but it was from 2009. Guess the security updates should be okay but who knows at this point.

    Thanks for the help and Happy Holidays!
     
  6. NOROCKETDOC

    NOROCKETDOC New Member

    Joined:
    Dec 23, 2011
    Messages:
    8
    Likes Received:
    0
    Just a final update since I've seen there were quite a few views on this thread. I've installed all security and Windows 7 updates and have had no trouble. My assumption right now is that an update did not install properly at some timepoint. I noticed some error messages when trying to unsuccessfully adjust my firewall settings. Probably the last few that were automatically installed last week. Don't believe it was a virus as I'm running current Norton software but always a possibility. I have shut off the auto download and install feature and now will do it myself. The only update I did not install was an Atheros driver upgrade from 2009. I feel this is not the problem since this is the one that was running fine prior to my connection issue but decided to not take a chance. Overall the complete cleanup and Win7 reinstall seems to have fixed my problem for now. Guess it's good practice to do such a cleanup from time to time anyway and luckily I lost nothing in the process.

    Hopefully this will help someone else if they encounter a similar problem.
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Thanks for updating your thread with your processes and steps to resolution. Sorry to hear that it required a complete re-install of the OS but I guess all's well that ends well or so they tell me.
    Thanks for joining our community and we hope to continue to see you around the forum.
    Regards
    Randy
     

Share This Page

Loading...