Windows 7 32bit does not support 4GB Ram but Vista 32Bit SP1 does! Help!?!?!

Discussion in 'Windows 7 Help and Support' started by Poincare, Jul 8, 2009.

  1. Poincare

    Poincare New Member

    Joined:
    Jul 8, 2009
    Messages:
    2
    Likes Received:
    0
    Hi. I have installed Windows 7 32bit and I have 4GB of RAM. However, W7 only reports 2.96 GB Ram usable while it does recognize there are 4GBs. Previously I had Vista 32Bit with SP1 and that fully recognized my 4GB. Can someone please inform me how to get W7 32bit to recognize the full 4GB of RAM like Vista 32bit SP1?

    Please do not tell me to install 64Bit W7, I already tried and my mouse, sound, Bluetooth, and iSight are unsupported in 64Bit as drivers are only available in 32Bit.

    I have already tried BCDedit.exe /set pae ForceEnable but that has no effect. So, please does anyone know a hack or trick or some setting somewhere that can enable the full 4gb?
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Hi Poincare, I hate to tell you this, but Vista x86 Sp 1 does show whatever total ram insalled there is, but it still does not use more than 3,3 gb because of the address limit with 32 bit number. That's it. It'll show you have 8 gb but will be actually using only 3,3.

    Choose which is more importat to you, and then choose it x 64 or x 86. Writing your hardware manufacture asking for x 64 drivers could help in time. Perhaps using 2 OS's x 64 and x 86 for different needs could be your practice for a while.
     

Share This Page

Loading...