Windows 7 64-bit issues with sound and video

krash

New Member
#1
I have Asus M2A-VM motherboard with onboard sound:
ATI Radeon HDMI @ ATI RV710/730/740 - High Definition Audio Controller PCI or
Realtek ALC883 @ ATI SB600 - High Definition Audio Controller PCI (not sure why there's 2 listed, used Everest to gather info)
upgraded video card:
ATI Radeon HD 4770 (RV740) Video Adapter

Problem:
Ever since installing Windows 7 Home Premium 64-bit (had to format XP off the hard drive first), windows is saying there is no sound hardware, which there is cus it's onboard. Aswell, when I go to play World of Warcraft it says "Failed to find suitable display device" yet there doesn't seem to be a problem with it, unlike the sound which has the little x on the speaker in my taskbar...
I have downloaded multiple drivers and checked my BIOS to make sure that Plug & Play OS was enabled, but still no changes... Please help.
 


Last edited:

reghakr

Essential Member
#2
What show up in Control Panel > Device Manager under sound, video and game controllers.

Also, are there any yellow flags nest to any entries?
 


krash

New Member
#3
Screenshot of Dvice Manager

This is a screenshot of the device manager, it only has the one alert.
I have an ATI Radeon HD 4770 (RV740) Video Adapter installed as well as the onboard video card... Not sure which this is, I assumed it was the onboard.
 


Attachments

Last edited:

reghakr

Essential Member
#4
That's strange,

That should have been installed by default when you installed Windows 7.

It's a typical component of Windows 7

Was this an upgrade or a 'clean' install?
 


krash

New Member
#5
I guess you'd call it clean, I had to format XP off the hard drive a few times. Had a bit of trouble getting past the "starting windows" screen, but eventually it went on to install.
As I said, I've checked the BIOS, and downloaded every driver available on Asus' website for my board... I am at a loss... No idea what to try from here, other then to reinstall.
 


reghakr

Essential Member
#6
How did you 'format' XP off the drive?

On install, did you choose the top box which would format the drive for you and save your files in a directory called C:\windows.old.

Not the second box which would be the upgrade route.
 


krash

New Member
#7
Fresh install, no change.

I have just tried reinstalling windows and and any drivers but still no luck... My boyfriend installed windows the first time when I was at work so I reinstalled today to make sure that it was done right.

Still the same bloody problem. Man this sucks....
 


#8
Workaround that works

I was having the problem with Windows 7 64 Premium. I found this work around for my Realtek Realtek ALC883 on a forum about a Creative soundcard, it worked for me, if you have more than 4 GB of RAM this probably isn't a good solution for you, but if you only have 4 GB then 1 MB less RAM to solve the audio problem is worth it. I've rewritten the instructions to apply to the Realtek issue:

:WORKAROUND:

You can use this as a temporary work around until it is resolved by MS or Realtek, without removing memory (RAM) physically (which also resolves this problem).

1) Uninstall all Realtek Drivers
2) Uninstall the High Definition Audio Controller under Device Manager > System Devices
3) Run MSCONFIG from Start Menus
4) select the boot tab
5) select advanced options
6) under max memory select 4095 (or any value under 4 GB is fine IE anything less than 1024 * 4)
7) Restart Computer
8) Go into audio preferences and set whatever device you are using as Default (usually this will be Digital Audio (S/PDIF (High Definition Audio Device)

9) Enjoy working sound!
 


reghakr

Essential Member
#9
I have just tried reinstalling windows and and any drivers but still no luck... My boyfriend installed windows the first time when I was at work so I reinstalled today to make sure that it was done right.

Still the same bloody problem. Man this sucks....
Was this a "clean" install or an upgrade.

If you went the upgrade route, your problems will follow along with it. The "clean" install method is the best.

Be aware, you'll need to re-install all your 3rd party applications.
 


#10
Re: Workaround that works

I was having the problem with Windows 7 64 Premium. I found this work around for my Realtek Realtek ALC883 on a forum about a Creative soundcard, it worked for me, if you have more than 4 GB of RAM this probably isn't a good solution for you, but if you only have 4 GB then 1 MB less RAM to solve the audio problem is worth it. I've rewritten the instructions to apply to the Realtek issue:

:WORKAROUND:

You can use this as a temporary work around until it is resolved by MS or Realtek, without removing memory (RAM) physically (which also resolves this problem).

1) Uninstall all Realtek Drivers
2) Uninstall the High Definition Audio Controller under Device Manager > System Devices
3) Run MSCONFIG from Start Menus
4) select the boot tab
5) select advanced options
6) under max memory select 4095 (or any value under 4 GB is fine IE anything less than 1024 * 4)
7) Restart Computer
8) Go into audio preferences and set whatever device you are using as Default (usually this will be Digital Audio (S/PDIF (High Definition Audio Device)

9) Enjoy working sound!
____
You made my day. I had read almost 500+ pages from different forums to get my sound back. This was caused after ram upgrade from 3GB to 5GB. Even Reinstalled windows and SP1. I joined this forum to thank you. I really really thank you from my heart. Several Hardware engineer haven't got luck with this nor software engineers. After boot CPU z shows full 5GB ram and my sound is also up and running. Quality is not better as before but I got first step towards it.
FYI my config:
Asus M2A-VM with on board graphic and sound.
AMD Athlon x2 64bit.
2x2 GB and 1x1GB DDR RAM
22" TFT LCD with 1920x1080
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.