Windows 7 64Bit RC1 won't install (missing cd/dvd driver issue?)

Discussion in 'Windows 7 Installation' started by acer123, May 24, 2009.

  1. acer123

    acer123 New Member

    Joined:
    May 24, 2009
    Messages:
    2
    Likes Received:
    0
    Hi All,

    I'm trying to install Windows 7 RC1 64bit (clean install) onto my Acer 6930G laptop. My current OS is Vista 32bit.

    I've burned the ISO to a disc on the slowest speed, the computer starts booting up then asks me to press any key to boot from the dvd, I do, it moves to a Windows Vista like loading bar (green) scrolling horizontally. After wards it loads up the Windows 7 install screen and says setup is starting. Then a window shows up saying a recquired cd/dvd driver is missing and I need to find it before I can proceed with the install. It gives me a screen with nothing listed and lets me browse the computer to find a cd/dvd driver (I assume) but I can't really find anything. I can even open the dvd with which I burned the ISO but can't continue with the install.

    I've tried using an external hard drive as a boot thing but I can't do that either from inside Windows FVista as it's only 32 bit.

    Also I tried installing it from a USB drive, exact same error!

    Any ideas? :frown:
     
    #1 acer123, May 24, 2009
    Last edited: May 24, 2009
  2. Stan

    Stan New Member

    Joined:
    May 27, 2009
    Messages:
    8
    Likes Received:
    0
    possibly..

    Have you tried that one on some other computer? You don't have to proceed with the install simiply test if you get past the point you get on yours...

    There is also a chance you may be dealing with a corrupt download or ISO.
     
  3. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello Stan,

    This has been documented and fixed for many.

    Click on the related links at the bottom of this page.
     
  4. jaysench53e@yahoo.com

    Joined:
    May 29, 2009
    Messages:
    4
    Likes Received:
    0
    I have had that same problem. I've updated the firmware on my computer to the latest version. No help.
    I've looked in the related links at the bottom of this thread, but it only says to retry burning the ISO on the slowest speed. I will try that, but I seriously doubt there was an error with the burn process that Nero 7.0 missed.

    I have Lite-On LH-20A1S DVD-RW drive. I'm attempting to install Windows 7 64 bit RC onto a clean drive. However, there is another drive on the system that has Windows XP Professional installed. I think perhaps that other O/S installation could be causing the problem. Anyone else find this error and possible fix? Please don't respond with smart remarks like "This has already been talked about" unless you can point to that specific article.

    Thanks.
     
  5. mike2k9

    mike2k9 New Member

    Joined:
    May 27, 2009
    Messages:
    184
    Likes Received:
    0
    I had the same issue. Surprisingly, it was fixed by going from a DVD -r to a DVD +r
    Won't work for everyone, but worth a shot

    And it wasn't a bad iso burn since I wasted 7 DVD -r trying it
     
  6. dvstech

    dvstech New Member

    Joined:
    May 29, 2009
    Messages:
    2
    Likes Received:
    0
    I had the exact same issue just now and fixed it by switching my DVD drive (Lite-On) from a 1.5 Gb/s SATA port to a 3.0 Gb/s one. The disk worked for me in a previous install on the exact same computer with a slightly different hardware configuration, so I don't believe there is any problem burning the ISO. I realize this doesn't help you on a laptop, but maybe it can help others on desktops :/
     
  7. Gazza

    Gazza New Member

    Joined:
    May 29, 2009
    Messages:
    52
    Likes Received:
    4
    had same problem

    But have not fixed it yet, I didi note that in one of the updates for win7 32 that there was a file that was related to a 64 bit install possibly the missing driver, remember this is not a final version so it will be missing files here and there, so maybe if you upgrade from the 32 version with the latest updates!!! or you could try flashing the bios with a 64 bit version.
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Did you guys try changing the jumpers on the DVD Rom?
     
  9. franky699

    franky699 New Member

    Joined:
    May 31, 2009
    Messages:
    4
    Likes Received:
    0
    had the problem and fixed it (read how)

    Many are saying it might be an incorrect download of w7. it didnt prove out in my case altough my first attempt to install poped up the same missing DVD driver as to many.
    Also lots are claiming it was something to do with the drivers (IDE or graphics or whatever else).

    I used my first and only download of w7 RC (downloaded 7 days ago) which didnt work on my DVD+R Verbatim burned by Alcohol on full speed (that missing driver error appeared). I downloaded free burning soft Active ISO Burner recommended on official MS web. Burned on 8x speed. Also removed my memory stick i had plugged in to my PC during my first unsuccessful install (not plugged in purpose - rather forgotten in my PC). Then tried to install second time and it worked...
    My way of fixing solution:
    - burning soft Active ISO Burner
    - burn 8x
    - remove memory stick from your PC
    That's all.
     
  10. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    franky699,

    Just curious, but can you provide a link to where you found recommended programs by MS?
     
  11. franky699

    franky699 New Member

    Joined:
    May 31, 2009
    Messages:
    4
    Likes Received:
    0
    link


    its the official site you should have gone thru just before downloading the official w7 RC file
    How to install the Windows 7 Release Candidate
     
  12. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    OK,

    I see now.

    It really isn't officially recommended by MS, it's just the posters in the forums opinion.

    Truthfully I've never even heard of it.
     
  13. qi6588

    qi6588 New Member

    Joined:
    May 31, 2009
    Messages:
    6
    Likes Received:
    0
    New to this forum but I encountered this error as well using an Intel motherboard, core 2 duo processor, and 2GB of corsair RAM. I had an older Seagate IDE disk and an older Pioneer IDE DVD burner. I think my burner was on its way out so I went to the store and bought a new Seagate SATA drive and a new Lite-On SATA DVD burner since my board supports SATA.

    My 2nd install experience went flawlessly. I am thinking that some of the older or less than optimum setups folks may have could be contributing to this sort of error. I know I may be grasping here but a change out of HW helped. I also wonder if Microsoft included the drivers needed for some of the older drives or if they have tight tolerances on data transfer rates from sub-par DVD HW.
     
  14. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I think the IDE drives will work fine, but yes it does happen many times where an older DVD Rom doesn't work.

    But being dirt cheap and better quality, it's a good idea to get one.
     
  15. jaysench53e@yahoo.com

    Joined:
    May 29, 2009
    Messages:
    4
    Likes Received:
    0
    Here's my opinion on the problem now:

    1. I think that since MS is still developing this software, that they probably have not added a full list of drivers for all devices and modes of drives.
    2. I think that a single drive can actually use several drivers, depending on the settings of the drive and motherboard.
    3. My drive is about 1 year old, so should work. However, I will need to tinker around with it's settings and the way in which the motherboard uses the drive, in order to trigger a different driver that is supported by RC.
    4. The comment that switching from DVD-R to DVD+R supports this theory. The comment about changing settings on a drive from 1.5GB to 3.0GB also supports this theory.
    5. I'll try these out systematically, when I get some free time to mess with it.
     
  16. Zeeke

    Zeeke New Member

    Joined:
    Jun 4, 2009
    Messages:
    2
    Likes Received:
    0
    Here's one possible (obvious) solution:

    I got the same annoying error.

    ,...So i just replaced the DVD +-RW drive. Picked up an old DVD-R from my junkbox.
    - It rocks !

    I'l will try to re-install the DVD/RW drive after installation. It might work....
     
  17. WardChristman@Hotmail.com

    Joined:
    Jun 11, 2009
    Messages:
    2
    Likes Received:
    0
    Switching SATA IDE to AHCI worked for me!

    FWIW, based on another forum's posts, the dreaded "A required CD/DVD drive device driver is missing" error during install of Windows 7 RC1. I do wonder if the DVD i burned had an issue and AHCI was able to handle it better? Either way, it worked for me after many attempts using IDE setting...

    Good luck everyone!
     
  18. bougar

    bougar New Member

    Joined:
    Apr 21, 2009
    Messages:
    6
    Likes Received:
    0
  19. andrew225

    andrew225 Well-Known Member

    Joined:
    Oct 9, 2009
    Messages:
    4
    Likes Received:
    0
    I have download Windows 7 Home Premium 32-bit from Microsoft Technet directly, so the ISO should be clean and tidy. I have encountered the same problem when I install it in Shuttle KPC K45 (945GC+ICH7), I wonder if it is really about the AHCI and IDE mode setting as ICH7 does not support AHCI mode, so there is nothing I can change in the BIOS at all. Then I burn the ISO into a DRD+RW disc and installed it in the K45 without any problems, that's the point, thanks a lot! But I really don't understand why it must be burned into a +R/+RW disc.
     

Share This Page

Loading...