Windows 7 64x System Tray Icon Limit


New Member
I have a Windows 7 Home Premium 64 bit OS installed on a machine with 8 GB RAM on a quad core processor.
I find one very strange problem very frequently from past few days.

The number of start up programs have increased gradually and this means that around 15 to 20 system tray icons appear in normal course. However, from past few days, few of these icons DO NOT appear at all thereby also not starting these programs. When I go to customize what icons appear on the task bar clicking the arrow near the system tray, it shows me most of these programs in the list but they revert back to "Only show notifications" instead of "Show icon and notifications".

When I do select "Show icon and notifications" for these programs, it displays a message that the icon will be shown the next time program becomes active.

How do I resolve this ? Is there any upper limit on number of icons that can be handled by default by Windows 7 Home Premium 64x OS ? If so, how do I increase the same ?

Any help will be appreciated.

Thanking in advance,


Senior Member
Try to "Reset default icon behaviors" and then go back into "Customize notification icons" and see if you can change them back to the way you want.

Also -- how many pinned programs do you have in the taskbar, is it completely full?


New Member
I have disabled few of the startup programs to reduce the clutter (about five to six of them) including some soundmax icons and UPS related non-critical programs, Adobe speed launcher etc. and again selected the start with Windows option in the programs which were not starting earlier and it seems to work now from few days.

On the taskbar, I have only absolutely necessary programs pinned (around 5 in total).

I think that there might be some default limit in the number of icons in system tray beyond which they tend to become unpredictable in behavior. If the limit can be increased somehow, the problem might be solved.


Essential Member
I don't believe theirs any limit.

First, Id go to Start > Run, and type msconfig. Uncheck all items except for your anti-virus software.

To dhow all icons, go to Control Panel, and check the box in the lower left corner.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.