Windows 7 and Icewind Dale 2

Discussion in 'Windows 7 Help and Support' started by Orestes, May 6, 2010.

  1. Orestes

    Orestes New Member

    Joined:
    May 6, 2010
    Messages:
    4
    Likes Received:
    0
    Greetings everyone. I am using Windows 7 Professional x64bit. I've currently installed Icewind Dale 2 (reminds me a great time back there in school years). I wanna play this game in lan.

    1) So, lets begin with some general problems. I have set Compatibility with Vista SP2 (wich is supported from the latest patch that i have downloaded) and when i am in-game(title screen) and trying to type anything, as a name of a player or a session's name, characters appear after i pressed them like 10 times, and its not a physical count error, it just a delay that the keyboard doesn't give all the input to the program, which is not happening to other (Vista) users.

    2) I'm using hamachi to begin with. When i try to host a game (after the slow typing problem) after hitting "Start local"(or whatever its in this game) everything's getting black and nothing happens if i wait. The music is still on like nothing happened. The only way to close it, was my *lovely* ctrl+alt+delete and end program.

    3) Now, if I try to join a LAN game. After I enter the TCP/IP address, I hit "Join" and I'm getting dropped to desktop, the program is still runing and i get huge icons, cause it keeps the resolution from the game (8000x600in-game and i have 1400x900 at my pc). I tried to wait, but after 10 minutes i decided to close it. Again the only way was the one above.

    I've googled it a lot as google is a friend o' mine and the only help i could get was to update my VDrivers, as I did. I didn't post this thread to networking support because I don't think that the problem lies there, as I'm getting dropped of the game. Thanks in advance for any response!

    PS: I'm not really good in English and I'm trying my best in order to explain my problem. I'm also studding programming so I can understand a bit more advanced terms.
     
  2. Orestes

    Orestes New Member

    Joined:
    May 6, 2010
    Messages:
    4
    Likes Received:
    0
    After a couple of hours, i've managed to skip 2 and 3 from above. Achieved this by running the game in windowed mode. We can connect to each other now, but after some secs we are getting dropped whoever is the host. That's a problem that i have also to post in network support. I still have the problem with the input and thats why i didn't count this thread as solved yet. So, any ideas?

    Thanks in advance.
     
  3. Sievel

    Sievel New Member

    Joined:
    Aug 17, 2010
    Messages:
    2
    Likes Received:
    0
    I had the same problem, as i was trying to set up a multiplayergame of IWD2 with my friends.
    I found your solution and then discovered that when you also run it as Administrator you can play it on Windows 7 without major problems. (only a few graphic bugs, but nothing that destroys the game so far)
    So just set up a shortcut to the IWD2.exe, right click and go under compatible settings (not sure what it is actually called in English) and there u have to set a cross by "Run programm with administrator access".
    At the moment i am not using Windows 7 myself so my Descriptions are from my mind only but i am sure that you can find better guides online, that describe the compatible mode and the administrator rights.
    I hope this helps you and maybe a few others that try to solve this problem.
    If you cannot decipher my rambling then just reply and ask.
    have a nice day...
     

Share This Page

Loading...