Windows 7 BSOD ntoskrnl.exe probable cause

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by mq1991, Jun 20, 2011.

  1. mq1991

    mq1991 New Member

    Joined:
    Jun 20, 2011
    Messages:
    8
    Likes Received:
    0
    Hey everyone! Ive searched high and low for an answer to this question, but i cant seem to find it anywhere.

    Recently, my computer will lock up and show a bluescreen that says a power driver state failure is the fault for the bluescreen. I examined the dump file and it syas that ntoskrnl.exe is the probable cause. Can anyone give me a direction in where to go?

    Dell Studio XPS 16 with Intel Core i7, ATi Radeon 5730, 6GB Ram, Windows 7 Professional.

    Thanks!
    -Steve Memory. CPU.
     

    Attached Files:

  2. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    Hello there,

    The dump file wasn't very helpful. But it's was pointing to some USB device I would recommend to disconnect all the USB devices and test the computer for few hours.

    If your Overclocking please stop and reset the BIOS to default settings.

    Code:
    DRIVER_POWER_STATE_FAILURE (9f)
    A driver is causing an inconsistent power state.
    Arguments:
    Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
    Arg2: fffffa8007c68060, Physical Device Object of the stack
    Arg3: fffff80000b9c518, Functional Device Object of the stack
    Arg4: fffffa8005ae2930, The blocked IRP
    
    Debugging Details:
    ------------------
    
    
    DRVPOWERSTATE_SUBCODE:  3
    
    IRP_ADDRESS:  fffffa8005ae2930
    
    DEVICE_OBJECT: fffffa8007c68060
    
    DRIVER_OBJECT: fffffa8006e45bb0
    
    IMAGE_NAME:  usbhub.sys
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  4d8c0c15
    
    MODULE_NAME: usbhub
    
    FAULTING_MODULE: fffff88007ea9000 usbhub
    
    CUSTOMER_CRASH_COUNT:  1
    
    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT
    
    BUGCHECK_STR:  0x9F
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  2
    
    LAST_CONTROL_TRANSFER:  from fffff800030f69c2 to fffff80003089d00
    
    STACK_TEXT:  
    fffff800`00b9c4c8 fffff800`030f69c2 : 00000000`0000009f 00000000`00000003 fffffa80`07c68060 fffff800`00b9c518 : nt!KeBugCheckEx
    fffff800`00b9c4d0 fffff800`03095652 : fffff800`00b9c600 fffff800`00b9c600 00000000`00000001 00000000`00000000 : nt! ?? ::FNODOBFM::`string'+0x34a90
    fffff800`00b9c570 fffff800`030954f6 : fffffa80`08b124a8 fffffa80`08b124a8 00000000`00000000 00000000`00000000 : nt!KiProcessTimerDpcTable+0x66
    fffff800`00b9c5e0 fffff800`030953de : 0000002c`026fb963 fffff800`00b9cc58 00000000`00127d07 fffff800`031ff368 : nt!KiProcessExpiredTimerList+0xc6
    fffff800`00b9cc30 fffff800`030951c7 : 00000006`dc09dac2 00000006`00127d07 00000006`dc09da88 00000000`00000007 : nt!KiTimerExpiration+0x1be
    fffff800`00b9ccd0 fffff800`03081a2a : fffff800`031fce80 fffff800`0320acc0 00000000`00000002 fffff880`00000000 : nt!KiRetireDpcList+0x277
    fffff800`00b9cd80 00000000`00000000 : fffff800`00b9d000 fffff800`00b97000 fffff800`00b9cd40 00000000`00000000 : nt!KiIdleLoop+0x5a
    
    
    STACK_COMMAND:  kb
    
    FOLLOWUP_NAME:  MachineOwner
    
    FAILURE_BUCKET_ID:  X64_0x9F_IMAGE_usbhub.sys
    
    BUCKET_ID:  X64_0x9F_IMAGE_usbhub.sys
    
    Followup: MachineOwner
     
  3. mq1991

    mq1991 New Member

    Joined:
    Jun 20, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks for the input, What ive noticed is that the problem only arises when I put the computer to sleep, and wake it back up. (With or without USB devices connected). It makes a series of "USB Disconnected" noises and eventually locks up. If i restart the computer the problem goes away.

    I have about 17 other dump files (some going up to 2GB). I can upload any of them if you think they could help?

    They are all from the same error.
     
  4. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    #4 Captain Jack, Jun 23, 2011
    Last edited: Jun 23, 2011
  5. mq1991

    mq1991 New Member

    Joined:
    Jun 20, 2011
    Messages:
    8
    Likes Received:
    0
    Yeah. :(

    W7.

    I looked through that article but my problem seems to only happen when it comes out of sleep, with or without usb anything connected.

    Usually I can sort these problems out myself... But this one has baffled me. Ive tried reinstalling Windows 7 as well, but a short time later it came back, I had AVG installed and saw that sometimes AVG has had bad effects on computers, so I replaced that with MSE. The only processes that I have running on the computer right now are bone stock processes.

    Could it be hardware related?
     
    #5 mq1991, Jun 23, 2011
    Last edited: Jun 23, 2011
  6. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    How old is your Laptop? Because if it's not software then it's best to talk to Dell before you run out of warranty.
     
  7. mq1991

    mq1991 New Member

    Joined:
    Jun 20, 2011
    Messages:
    8
    Likes Received:
    0
    Haha its only about 8 months old. I have the 3 year extended warranty on it, so im not too worried about anything hardware etc.. But the thing that has me irratated is that I went through and redid my computer with a fresh install and programs, and now its doing the same thing.

    Hmmm... scanning through the event viewer, I see that something to do with the .net framework keeps popping up right at the time I come out of standby, to he point the computer executes itself.

    Should I try removing that?

    By the way, Jack, I see that you are a MAJOR contributor here, I just wanted to say thanks for taking the time to help me with this. Every time I stop by I see your name all down the Recent Replies list :eek: haha

    Thanks again!
     
  8. Captain Jack

    Captain Jack Extraordinary Member

    Joined:
    Mar 6, 2010
    Messages:
    1,952
    Likes Received:
    139
    Thanks. Microsoft .NET Frameworks are build-in to the OS so we can't remove it. Most of the times .NET Framework errors means it's some application that's build with .NET Frameworks. After reinstalling Windows did you install another application. Try to run it vanilla(Without any software)

    Enable Driver Verifier Using Driver Verifier to identify issues with Drivers - Windows 7 Forums
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    mq1991:
    Hello and welcome to the forums.
    Just wanted to say that it was very nice of you to recognize and compliment Captain Jack regarding his many and very valuable contributions to this forum. As a forum member and moderator and MVP he has an incredible amount of personal expertise and experience which he selflessly shares with other members here inorder to help them with their problems. Not the least of which is his uncanny abillity to help members resolve their BSOD issues.
    It's rare but extremely nice to see him recognized and appreciated for all his efforts on this forum.
    So I just wanted to say thank you and let you know that we all hope to continue to see you around this forum as well.
    Best Wishes
    Randy
     
    1 person likes this.

Share This Page

Loading...