Windows 7 cannot see MSHOME or XP computers

#1
I was able to see the workgroup MSHOME computers for 5 minutes. After I rebooted the computer, I couldn't see any of them. However, \\ip_address\ or \\ip_address\share_name works. Network discovery on the network is slow (on the Windows 7 computer)...it takes 45 seconds to detect all the computers. The router I am using is D-link DIR-628 . This same problem has plauged me in Vista. The funny thing is...I am able to see the Windows 7 computer from XP computers just fine and quickly too. I can ping from XP to Windows 7 just fine. What other information should I give that would help you? Thanks!

Here is IPCONFIG from Windows 7:

Microsoft Windows [Version 6.1.7127]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Matthew>ping 192.168.0.193

Pinging 192.168.0.193 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.193:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\Matthew>ping 192.168.0.193

Pinging 192.168.0.193 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.193:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\Matthew>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : vc.shawcable.net
Link-local IPv6 Address . . . . . : fe80::adde:a887:bcdf:1b1e%11
IPv4 Address. . . . . . . . . . . : 192.168.0.129
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

Tunnel adapter isatap.vc.shawcable.net:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : vc.shawcable.net

Tunnel adapter Local Area Connection*:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:3014:1a3a:9fce:9146
Link-local IPv6 Address . . . . . : fe80::3014:1a3a:9fce:9146%13
Default Gateway . . . . . . . . . : ::

C:\Users\Matthew>
 


#2
I was able to see the workgroup MSHOME computers for 5 minutes. After I rebooted the computer, I couldn't see any of them. However, \\ip_address\ or \\ip_address\share_name works. Network discovery on the network is slow (on the Windows 7 computer)...it takes 45 seconds to detect all the computers. The router I am using is D-link DIR-628 . This same problem has plauged me in Vista. The funny thing is...I am able to see the Windows 7 computer from XP computers just fine and quickly too. I can ping from XP to Windows 7 just fine. What other information should I give that would help you? Thanks!

Here is IPCONFIG from Windows 7:

Microsoft Windows [Version 6.1.7127]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Matthew>ping 192.168.0.193

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : vc.shawcable.net
Link-local IPv6 Address . . . . . : fe80::adde:a887:bcdf:1b1e%11
IPv4 Address. . . . . . . . . . . : 192.168.0.129
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1

Tunnel adapter isatap.vc.shawcable.net:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : vc.shawcable.net

Tunnel adapter Local Area Connection*:

Connection-specific DNS Suffix . :
IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e50:3014:1a3a:9fce:9146
Link-local IPv6 Address . . . . . : fe80::3014:1a3a:9fce:9146%13
Default Gateway . . . . . . . . . : ::

C:\Users\Matthew>
from what I see your using a draft N router, your ip is .129 . your routers is.01, and win 7 is on .193 . correct? Do you have win 7 on workgroup?
 


#3
Yup they are on the same workgroup
 


dre@ms

New Member
#4
wat abt the dns entries? Try ipconfig /all in cmd and post the results.
also let us know what is the error msg u recieve when trying to access other computers.
 


#5
Hi,

I am not sure if this will help in your case but I found the only way to get my XP and W7 PCs to talk was rather drastic. I had a problem in that neither pc could ping each other, so networking was never going to work.

I checked the arp table and found that they were not getting any arp responses. I added a static arp on each machine and hey presto it sprang into life (
To set a static arp entry for the PC you wish to connect to open a command prompt and type: arp –s “IP address” “MAC Address”

I am going to take the entries out and I will do a packet capture but as a workaround this may help you out for the moment.

Cheers.
 


#6
Have you turned on network discovery in the Network Sharing Center in W7? Right click the network icon in the task tray and open network sharing to check.
 


#7
XP can't see w7 computer

I'm having a similar problem. My W7 computer can "see" my XP computer, but not vice versa. What can I do in XP to "see" my W7 computer?
 


#8
W7 computer can "see" my XP computer, but not vice versa

I'm having a similar problem. My W7 computer can "see" my XP computer, but not vice versa. What can I do in XP to "see" my W7 computer?

I have the same problem
 


#9
Change setting "Allow Windows to manage homegroup connections (recommended)"
to "Use user accounts and passwords to connect to other computers". This should let your windows 7 computer see all the computers on your home network regaurdless of the operating system.

The setting is under Network and Sharing Center > Advanced sharing settings
Home or work (current profile)
HomeGroup connections
 


#10
Microsoft has a hotfix for the LLPT in Windows XP that will also make it so that windows 7 computer will see windows xp computers.

KB922120-v6-x86
fix215806
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.