Windows 7 can't install language, getting Windows Update error: 80070490.....help!

Discussion in 'Windows 7 Help and Support' started by chaoscreater, Feb 2, 2010.

  1. chaoscreater

    chaoscreater New Member

    Joined:
    Jan 11, 2010
    Messages:
    10
    Likes Received:
    0
    First off, for some reason I can't load this page properly on Opera browser, everything seems to be loaded but when i put my cursor in either the Title or Body box to start typing my message, it doesn't work, and it's not lag either, it's like as if a script or something is blocking it, sort of like when you turn off Javascript, Youtube videos don't load properly, anyway i'm just pointing that out.


    Ok so for my main problem, i've never got this error before. I'm using Windows 7 Ultimate x86. I'm trying to install the chinese language pack on my english Windows 7, and i've always done that without a problem. Well, i've reformatted my laptop yesterday and tried to install chinese language from windows update, it downloads and begins to install but then cancels and shows this message:

    Code: 80070490.


    I did a Google search on that error code and already tried tons of solutions and they don't work. So then i decided to try my backup disc which contains the language packs in .cab format, which i downloaded from MSDN (legit). BTW, I've done this before so i know what i'm doing.


    After finding my disc, I then proceed to install the language pack by going to Regional Languages and locate my disc, and it detects the .cab files but it shows an error message saying that it's corrupted or something, which can't be right because i used that disc several times on my other PCs, i even tested it on another PC just to see if my disc was corrupted and it works fine.


    So, what do i do?? I've tried almost every solution possible. I did a sfc /scannow, chkdsk /r and installed windows update agent, i also installed the update KB947821 which is something to do with windows update if i remember correct. My Windows Update works fine anyway, it downloaded and installed a few updates already, so i dunno why it's not working now.

    My system is clean btw, i only just reformatted my PC yesterday so it's VERY fresh and clean, i also have installed Comodo Internet Security and Microsot Security Essentials and Avira Antivirus so my system is very clean.


    I haven't installed anything else and i've never had this problem be4, i've installed Windows 7 and the languages at least 8 times now and this is the first time i have this problem.


    I've taken ownership of my entire C:/ drive as well and has grant it full permission too, i'm running as admin as well.
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    #2 cybercore, Feb 2, 2010
    Last edited: Feb 2, 2010
  3. chaoscreater

    chaoscreater New Member

    Joined:
    Jan 11, 2010
    Messages:
    10
    Likes Received:
    0
    Hi, that's actually what I did, i got them from the exact same download links.

    Then, i used EXE2Cab to convert the .exe installers to .cab file, because if you simply run the .exe installers after you downloaded them, nothing will show up, and plus the languages can only be recolonized as .cab files when you go to the Regional & Languages setting to install them, so you have to convert it to .cab files.

    I did that and still getting the corrupted/invalid error.


    And i already tried disabling my AV & firewall be4 install...
     

Share This Page

Loading...