Windows 7 Claims My "Line In" Not Plugged In

#1
My speakers work fine, I can listen to things fine. I can't however seen to record anything coming out of my speakers. When I look at my recording devices it shows Microphone (plugged in) Line In (Not Plugged in) and Digital Audio S/PDIF (default device).

I don't understand why I can't record music playing from my speakers.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
How are you trying to record it?
 


#3
I've tried various recording softwares I used all the time prior to 7 (Cool Edit and Audacity). Nothing works. And like I said, when I click on my sound properties in the lower right corner of my taskbar it says its not connected, which makes no sense.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
Have you tried plugging something into the line in port to see if you can record that?

There is supposed to be an AUX port somewhere, but I haven't found it yet. I will check around to see if I can.
 


Last edited:
#5
I can record through my mic and such. I'm rather puzzled.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
I am not really sure what might be going on, but it might be connected to the Digital Rights. Many of the options that were in XP are not in Windows 7. It appears the wdmaud.drv was responsible for many of the mixer, input/output selections in XP are are not present in Windows 7.

I also have HD audio on my board. Maybe one day I will obtain some equipment that will allow me to take advantage of it. :rolleyes:

You may want to spend some time in a audio/visual type forum to see if they have more experience with this situation. They might recommend using a patch cable.
 


Last edited:

ooydoboora

Senior Member
#7
Guys, this could've been something simple, like the default device, for example?..



Just check the settings, from the Windows Control Panel, as Vista & 7 tend to mix things up. Again, for example, my ASUS AH3650 has HDMI and after installing its default software & the motherboard integrated soundcard default software, those jacks tend to mix up; just stupid programming, on behalf of Micro$oft.

P.S.
Here's the screenshot from the example above, why I don't get playback before I switch the defaults on my machine:

 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.