Windows 7 color washout problem (too bright/high contrast)

Discussion in 'Windows 7 Help and Support' started by stingray620, Nov 8, 2009.

  1. stingray620

    stingray620 New Member

    Joined:
    Nov 8, 2009
    Messages:
    2
    Likes Received:
    0
    I just installed Windows 7 Pro on an HP Pavillion with an HP w2007 20" monitor. I had no color issues initially and everything worked fine. The first time I ran Windows Update, it included an optional update called "HP- Display - HP w2007 Wide LCD Monitor". That update "failed" to install and when I rebooted, my screen had a very "neon" look to it - my desktop background, a picture of a tree with a bunch of red leaves, was very washed out and most of the leaves were now bright red with no details visible. This is evident everywhere, not just my desktop background (another example...the little green circles next to contact names in Gmail chat are very bright green, more so than usual). Everything is too bright. I have tried the following fixes:

    -Reinstalling the HP display update manually (it worked this time) and rebooting - didn't work.
    -Resetting my monitor to the factory defaults - didn't work.
    -Downloading and installing the latest HP driver for this monitor - didn't work.
    -Going through: "Control panel -> Appearance and Personalization -> Display -> Calibrate Color" and going through a color calibration wizard (believe that's new to Windows 7?). Also didn't work.

    I have dual-boot to Ubuntu set up on this machine and I believe the colors in Linux are still fine, so I think it's a problem with Windows and not the monitor. Since it was working fine before, I would rather try to get it back to whatever was working, rather than manually tuning the brightness/contrast of my monitor. Any ideas?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If it happened after the Windows update like you state, the chances are very likely that was the problem. Did you uninstall the update?

    When I was running Vista they put out a Nvidia update which messed my system up.
     
  3. kocoman

    kocoman New Member

    Joined:
    Nov 2, 2009
    Messages:
    4
    Likes Received:
    0
    I am having the same problem too, after I install the update the colors become too red. how to fix it?
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You might try going to Personalize by right clicking on the desktop, then Display on the bottom left, then Calibrate color on the left. If that doesn't work, there is probably a color management under you graphics adapter using screen resolution option.
     
  5. dap1059

    dap1059 New Member

    Joined:
    Nov 11, 2009
    Messages:
    4
    Likes Received:
    0
    I had the same problem. I worked with HP support by phone and they reinstalled the original driver for the Nvidia card. Then they hid the update driver that was causing the problem so that W7 would not automatically reinstall it. I also set the auto update to get my permission before installing anything. It was very simple...I wish I could remember the steps but my brain was mush after spending several hours reading forums searching the web etc. If I remember the steps I'll post later.
     
  6. NightAvatar

    NightAvatar New Member

    Joined:
    Nov 11, 2009
    Messages:
    6
    Likes Received:
    0
    I had this problem too, figured out a fix

    I had this problem too!

    In my case it was also due to a Windows Update driver called "nVidia display".

    Luckily I figured out how to fix it:
    1. Open Computer Management (Start > right-click "Computer" > Manage)
    2. Select "Device Manager"
    3. Select "Display adaptors"
    4. Right-click "NVIDIA GeForce 8600 GT" (or whatever your video card is)
    5. Click "Properties"
    6. Select "Drivers" tab
    7. Click "Roll Back Driver" button
    That fixed it for me. Let me know if this helps! :)
     
  7. dap1059

    dap1059 New Member

    Joined:
    Nov 11, 2009
    Messages:
    4
    Likes Received:
    0
    yes ..a simple roll back will work if it hasn't been done. In my case I did it and later W7 reinstalled the bad driver through auto updates. Afterwards I couldn't find the factory driver. HP support directed me to use the HP recover manager which will load the original factory driver. Simple step by step process. After installing factory driver it is Very important to go to W7 auto updates and find the Nvidia driver that is waiting to be install as an upgrade and hide it.

    good luck
     
  8. J-Swifty

    J-Swifty New Member

    Joined:
    Dec 2, 2009
    Messages:
    6
    Likes Received:
    0
    Second edit... thought I solved the problem using the above post's advice, but it seems I haven't. I downloaded the original driver, and it works, but when I check Windows Update there's no option for updating the driver for me to uncheck. Everytime I restart I just have to reinstall the driver again, as the colors shift during the Windows 7 load screen.
     
    #8 J-Swifty, Dec 2, 2009
    Last edited: Dec 2, 2009
  9. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Go to Windows Updates, change Settings, choose "Download updates but let me choose whether to install them".

    Then choose Recommended updates to Give me same way as important.
     
  10. J-Swifty

    J-Swifty New Member

    Joined:
    Dec 2, 2009
    Messages:
    6
    Likes Received:
    0
    I've just tried this, but I'm still not getting an option to uncheck the update from installing. I've tried checking for updates both before and after reinstalling the old driver, after restarting, and it just says Windows is up to date
     
  11. silentx

    silentx New Member

    Joined:
    Dec 13, 2009
    Messages:
    2
    Likes Received:
    0
    heya everyone. i came across this while googling for help on the same problem with windows vista. i believe ive come to a really simple solution.

    if you go into your nvidia control panel you should see Display -> Adjust Desktop Colour Settings.

    through here you can adjust something called "digital vibrance" i've knocked mine down to +22% and everythings in ship shape.

    hope this may work for you guys on windows 7
     
  12. J-Swifty

    J-Swifty New Member

    Joined:
    Dec 2, 2009
    Messages:
    6
    Likes Received:
    0
    This seems to have done the trick! Everything still looks great even after restarting! Thank you very much!
     
  13. mjehamy

    mjehamy New Member

    Joined:
    Feb 25, 2010
    Messages:
    2
    Likes Received:
    0
    dude thank you so much. It wasnt esactly these steps for some reason but close enough to the resolve. Had from step 2 was open system tools<scroll to device manager<then the rest all fit in from there. But thanks again man, I though my eyes were going bad until I realized there was a problem.
     
  14. pmaa

    pmaa New Member

    Joined:
    Apr 24, 2010
    Messages:
    2
    Likes Received:
    0
    thanks guys, your suggestions above really helped. I had installed Win 7 and had done the update for the NVIDIA display driver for GeForce 9800 gt card that seems to be the source of the problem. It does seem to be a "color vibrance" issue. I went throught the steps of adjusting the "digital vibrance" throught the NVIDIA control panel as described above and it worked. I still felt like the display colors were still somehow a little different from what I remember them being before the Windows update so I rolled back my display driver and everyhthing was back to normal. The problem driver seems to be the nVidia Display software update released in June, 2009 -- "nVidia - Display - NVIDIA Geforce 9800 GT."
     

Share This Page

Loading...