Windows 7 CPU Usage Always at 100%

#1
Hi all,

Recently installed the 64 bit Windows 7 beta, and my CPU usage is constantly at or near 100%, even with no external programs running. Just to give a quick run-down of my system, I have:

-- AMD Athlon 64 3200+ Processor (2.2 GHz)
-- 2GB DDR RAM
-- 1GB Diamond Radeon 3650HD Video Card

The rest of my setup is a basic desktop machine -- plenty of storage space, etc. It runs XP Professional (32-bit) just fine. I installed the Vista x64 driver for my video card last night; it installed successfully, but did not seem to help much.

Should I abandon the 64-bit version and stick with 32 bit? Will that lessen the load on my CPU, or is there another problem here that I am not seeing? Any input would be appreciated.

Thanks!
 


iroken22

Extraordinary Member
Premium Supporter
#2
interesting problem we have here. Have you installed any new software since you first installed Windows 7? What Power mode is your computer set to?
 


#3
The only software I installed was the Catalyst Control Center that came with my video card driver. It's just a graphic card management utility, and I didn't see any appreciable difference in performance or CPU usage before and after that install. Other than that, I just have a fresh Windows 7 install.

When I open task manager, the CPU always shows 100% usage. If I have nothing else open, it hovers around 50% usage by explorer, and 50% by task manager. When I open up IE, it splits between IE, windows explorer, and task manager, each using around 33%. I turned off Defender, search indexing, and windows firewall after reading advice on other forums, but that did not seem to help.

In terms of "power mode", I am not sure what you are referring to. Are there any settings there that I should look into? If there is a potential problem with power mode settings I would love to learn more.

Anyway, thanks for the reply iroken22.
 


#4
Hey everyone, just wanted to stop back in and let you know I tried installing the 32-bit version, and it was definitely not the problem. Same exact symptoms. This is sort of sucking, I wanted to try this baby out, and my specs should easily be handling it.
 


#5
delete past history and see if explorer goes down in task manager. Task Manager should tell the which processes are using the cpu. All are usually around 0 or something is up.
 


#6
Oh yeah, something is definitely up. I opened up process explorer, and it is showing 80% or more CPU usage going towards "hardware interrupts", listed under system idle processes. My XP install virtually always shows 0% here, and after reading around on some other forums, I think that surely has something to do with the problems I am having.

Anybody know of any obvious driver updates or tweaks I should make? I assume things like hard drives and other major components should be configured correctly. To me, it seems like the most likely suspects would be my DVD drive (HP 740b) and my video card (Diamond Radeon 3650HD).

I'm going to do some messing around when I get home from work today, and I'll let you all know if anything helps. Any further thoughts would be much appreciated. Thanks!
 


#7
Hey all, just wanted to let you know that the problem ended up being with an audio controller. I went into device manager, and under the "System Devices" category there was an entry for "High Definition Audio Controller". The instant I disabled this, I had my machine running perfectly.

Anyway, thanks for all your help, and make sure to check into that if you are havinhg CPU usage issues.
 


#8
CPU usage 100% could be ffdshow codec issue

I had an issue with ffdshow_beta6_rev2527 on my P4 was at a 100% CPU all the time.

Installed CoreAVC pro, disabled codecs for H.264 in ffdshow and now CPU is on 4% - 10% usage like normal.

Also my PC can now playback 720p MKV files with DTS with very little frame drops in Media Center.
1080p is too much for it still but considering its a AGP 8x Video Card I dont think I can complain.

[MEDIA CENTER WIN7; P4 2.8Ghz; ATI Radeon 7500 512MB; 2GB RAM; 3WARE SATA RAID 0; SEAGATE SATA 500GB x 2; WD SATA 260GB x 1; ATI Radeon x1650; Creative SB Live 24bit EXT via SPDIF; LOGITECH THX Z-5500 Digital; Divico FusionHDTV DVB-T Dual Tuner; Panasonic TH-50PZ800A 50"]
 


#9
and now CPU is on 4% - 10% usage like normal.
Hmmm...

My idle CPU usage is normally between 0-4%.

If it was 4-10% I would be looking for something abnormal.
 


#10
Hi have the same problem

My Cpu runs at 100% when nothing is on - Desktop is running very fast

As someone said it was the audio device of something - I cant wait to try that.

Thankx
 


#11
I have/had the same problem.

It was caused by audiodg.exe. I "fixed" it by disabling on-board audio.

This was apparently a problem in Vista, that's where I found the solution
 


#12
Hi people, i had the same problem, i suggest you guys open the task manager and on the performance tab click on resource monitor there on the CPU tab you will see what is draining your cpu, here it was the Windows Media Player Network Sharing Service,
aka wmpnetwk.exe.
I just Disabled the service, restarted and now its fine.
hope it helps.
 


#13
This worked for me as well. I have the SB Audigy 2. Shutting down the HD sound instantly lowered the CPU utilization to ~ 1%
 


#14
I went to resource monitor and discovered my problem was with spoolsv.exe. I stopped the process and CPU usage went from 100% to about 20%. The problem started again when I tried to access my printer. Seems that always causes the problem. Everything gets locked up in the device window and the cpu jumps up to 100% immediately. How do I correct this? Do you think the RegistryBooster might solve my problem???
 


#15
To Linda

Hi Linda, your problem may have something to do with the print spooler service. Here's a page that sounds like it describes your issue:

How to Fix Spoolsv.exe high CPU utilisation problem - OCWorkbench Forum | C3 Fair - Computers, Communications & Consumer Electronics 2009 Fair | IT Show 2010 Price List Offers Brochures Flyers | Android phones | twitter, facebook, SEO, Investment, US


Basically it sounds like you need to turn off your printer and then stop the Print Spooler service (in Win7, you can just search "services" from the start menu search box and then select "View Local Services" in the results). Once you've stopped that service, you should go into C:\WINDOWS\system32\spool\PRINTERS, delete whatever files are there, and close the folder. Then just turn your printer back on, start up the Print Spooler service again, and you should be all set.

Hope that helps!
 


#16
Re: Hi have the same problem

I had the same problem and it was my explorer usin the 100 cpu.., and i found., it was the a corrupted .flv file on my desktop was causin a bug lyk dat.., and i found the appreciable answer here pls check out that. I guess it may be summthin related patto said.
 


#17
i had the same problem with high CPU on my Windows 7 laptop, i fixed it easily just

1) Open Task Manager
2) go to processes
3) find sidebar.exe right click on it
4) go to Set Priority and select Low

that worked for me so hope it will for you
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top