windows 7 driver power state failure caused by ntkrnlpa

#1
Hi,
I wondering if someone could help.
I finally managed to install my Western Digital MyBook World Edition but now it takes 20min for Win7 to shut down and I end up with a BSOD.
I run the latest version of Win7 and all software and driver are updated.


==================================================
Dump File : 081710-20389-01.dmp
Crash Time : 17/08/2010 12:21:19 PM
Bug Check String : DRIVER_POWER_STATE_FAILURE
Bug Check Code : 0x0000009f
Parameter 1 : 0x00000004
Parameter 2 : 0x00000258
Parameter 3 : 0x85c299a8
Parameter 4 : 0x83171b24
Caused By Driver : ntkrnlpa.exe
Caused By Address : ntkrnlpa.exe+67966
File Description : NT Kernel & System
Product Name : Microsoft® Windows® Operating System
Company : Microsoft Corporation
File Version : 6.1.7600.16617 (win7_gdr.100618-1621)
Processor : 32-bit
Computer Name :
Full Path : C:\Windows\Minidump\081710-20389-01.dmp
Processors Count : 2
Major Version : 15
Minor Version : 7600
==================================================

The dump file is here https://cid-cee0b01b7fe65fa7.office.live.com/self.aspx/.Documents/081710-20389-01.dmp

Someone could help pleaseeeeeeeeeeeeeeeeeeeeeeee.

Thanks a million.
 


Attachments

#2
You say "finally", what was the problem you had installing the thing? Could be related. What software have you installed to support the drive? Have you tried updating that software?
 


#3
The finally was related to the first WD MyBook was dead on delivery, so i waiting for a replacement. It seems there is a common problem for WD MyBook not been recognised by Win7, mine worked fine and i was able to map all my folders. All on this side works perfectly and i using Western Digital Discovery to support the drive.
The 'only problem' is when i restart/shut down the laptop it takes like 15/20min and i get the BSOD.
 


#4
Hey there. You have a very simple issue. It is this driver:

Code:
SahdIa32 SahdIa32.sys Mon Apr 07 22:40:15 2008
and this one too:

Code:
SaibIa32 SaibIa32.sys Tue Oct 09 04:24:03 2007
To fix the issue, uninstall all of your Sonic Solutions software. Here is a link to help you understand which that may be (DVD stuff):

Sonic Solutions - DVD Burning - DVD Decoder - DVD & Video Editing Software


----------

The above will entirely fix your issue, but to better your system, please uninstall all Arcsoft software since it has installed old drivers.

----------

Update your Realtek HD Audio driver from the following link:

Code:
 RTKVHDA  RTKVHDA.sys  Thu Jul 02 05:28:49 2009
Realtek

-----------

Visit Sony's site for your particular hardware. Download and install the latest Sony Firmware Extension Parser to update this driver:

Code:
SFEP     SFEP.sys     Fri Aug 03 01:36:08 2007
-----------

While at Sony's site, please also download and install the latest ALPS touchpad driver to update this old one:

Code:
Apfiltr  Apfiltr.sys  Wed Dec 12 04:01:21 2007
----------

It would also be good to download and install the latest card reader drivers to update this old one:

Code:
rimsptsk rimsptsk.sys Tue Sep 02 02:29:49 2008
----------

Again while at Sony's site, download and install the latest Marvell Yukon networking driver to update this old one:

Code:
yk62x86  yk62x86.sys  Mon Feb 23 09:44:18 2009
---------

And yet again, while at Sony's site, download and install the latest Intel networking driver to update this old one:

Code:
netw5v32 netw5v32.sys Thu Mar 26 12:10:37 2009
 


#5
brilliant, it works... it seems it was the Sonic/Roxio software caused the issue.
 


#6
Cool. Thanks for the update.

Now install those other drivers I've mentioned if you haven't already done so, so there will be no issues in the future. :)

Enjoy.
 


#7
I could find updated drivers for Realtek, however it seems Sony doesnt provide newer driver for then the once above. The laptop is already 16 month old, maybe thats why :) and its Sony.

Thanks again for your help.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top