Windows 7 Ethernet over USB works but is very slow to acquire IP Address

Discussion in 'Windows 7 Networking' started by phil999, Jan 17, 2013.

  1. phil999

    phil999 New Member

    Joined:
    Jan 17, 2013
    Messages:
    4
    Likes Received:
    0
    I have a Windows 7 64-bit Professional machine connected to the internet through a Netgear N300 Router. I also have a small Linux based camera that does Ethernet over USB. When I plug in the Linux device to the Windows 7 machine, it takes about 50-60 seconds to obtain an IP Address on the 10.XXX.00.X network from Windows. In Windows XP with the same configuration, the IP Address is obtained almost immediately!


    After the minute of waiting, everything is fine. I can ping and otherwise use the connected Linux device anyway I want.


    Why does it take so long to obtain an IP Address for the device under Windows 7 and how can I troubleshoot or fix this? Is there some sort of priority setting needed?

    Thanks!



    NOTE:
    Using Microsoft Network Monitor when I plug in my device I immediately receive the following:


    271 9:26:07 AM 1/17/2013 218.8801397 0.0.0.0 255.255.255.255 DHCP DHCP:Request, MsgType = REQUEST, TransactionID = 0xBDBD6E0C {DHCP:53, UDP:7, IPv4:6}
    272 9:26:07 AM 1/17/2013 218.8812374 10.130.0.2 PC-MSP-183B DHCP DHCP:Reply, MsgType = ACK, TransactionID = 0xBDBD6E0C {DHCP:53, UDP:7, IPv4:6}
    273 9:26:07 AM 1/17/2013 218.9334041 0.0.0.0 PC-MSP-183B ARP ARP:Request, 0.0.0.0 asks for 10.130.0.1
     
    #1 phil999, Jan 17, 2013
    Last edited: Jan 17, 2013
  2. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    I'm just guessing here...but I've noticed that the device is using IPv6 where windows 7 natively uses IPv4...same as XP. I would suggest turning off the IPv6 for your network adapter in the properties menu. Seems to be a conflict when trying to decide which one to use which is causing the delay for connection. Like I said, it's just a hunch I have.
     
  3. phil999

    phil999 New Member

    Joined:
    Jan 17, 2013
    Messages:
    4
    Likes Received:
    0
    Thanks, I disabled everything under network adapter properties for my adapter except for ipv4 but still it takes the long amount of time to get an IP Address. Do you have any other ideas?
     
  4. bassfisher6522

    bassfisher6522 Essential Member

    Joined:
    Aug 27, 2008
    Messages:
    4,878
    Likes Received:
    317
    The other options I can suggest would be reboot the router by unplugging it from the power outlet for 1 minute and then plugging it back in and checking. The next thing would be to check for a firmware update for you router.
     

Share This Page

Loading...